Recording from Cassette tape

I am recording voices from cassette tape. I have Windows 7 and the latest version of Audacity. It records the voices fine but automatically shuts off after about 20 minutes even though the tape is still playing. I would like a 45 minute track rather than chopping the digital into smaller tracks. How do I get Audacity Record to stay on for the full 45 minutes?

Audacity just stops recording, or it’s recording and the signal goes flat?

Audacity has a timer tool.

Transport > Timer Record.

Also make sure Snap To and the other values at the bottom of the screen aren’t set.

Audacity may also stop recording if there’s no place to put the work. Are you running out of hard drive space?


Also make sure you don’t have a selection of 20 minutes present, or recording by default will stop after 20 minutes.

Please see the pink panel at the top of the page for how to give us your Audacity version (I moved your post here from “Feedback and Reviews”).


I have Audacity version 2.0.6. I installed it earlier this year off the internet using exe installer. I am using AGPtek cassette player with USB port into an HP computer with Windows 7. Audacity just stops recording, the first time after about 34 minutes, the second time after about 20 minutes. In each case the cassette player continues to play the recording, which I can hear through the earphone. There is no flatline recording on Audacity. It just stops. I checked the Transport>Time Recorder and all settings are well over 1 hour. Snap To and all other settings at bottom are off. The tape is a C 60 with 30 minutes on each side. I start recording about 15 minutes into the tape on side 1, as that is the conversation I want to capture. The tape player automatically switches to side 2 and continues without a break. Audacity recorded the first 15 minutes on side 1 and continued recording into side 2 and then stopped about 20 minutes during my first attempt, and then about 10 minutes in the second attempt.
I can’t figure out why Audacity stops recording even as the tape continues playing.

Have you considered that your computer might go to sleep and cut the audio?

Those settings only apply if you actually start recording by choosing Transport > Timer Record… .

Try rebooting the computer.

If the problem persists, try changing the USB cable. Make sure the cable is connected tightly both ends.

Make sure at Edit > Preferences…, Recording section, that Audio to Buffer is at least 100 milliseconds (which is the default value).


Should any computer go to sleep when it is writing files every 6 to 12 seconds as Audacity does when recording?

The screen saver might come on, but this should not cause the recording to stop.


Actually, the computer screen does go to sleep (goes black) during the recording, but I figured it was just the screen saver and Audacity was still working. I tap the space key on the keyboard and the screen comes back on but Audacity has shut off. I guess I can stay there and keep the screen on. any other ideas?

I agree, it shouldn’t. But it does.

It doesn’t really stop recording, or writing to disk. But the mere fact of going to sleep (or in other cases, waking up), is enough to provoke a spike of latency. Some audio drivers give a dropout, others just lock up.

I’ve seen this occasionally on all OSes and it is hardware dependent. If you have a computer with that chipset, you could run into trouble. It also depends a lot on the software installed. A typical overladen computer with lots of leftovers from installs will produce it more often than a clean, unconnected studio DAW.

And anything might fix it. Temporarily, usually.

Most people do not record for hours in one session. And that’s the reason most people do not see the bug.

My screen dims. But my HD and CPU never go to sleep. And that’s the setting I see on every audio engineer’s computer I have ever seen.

It gets even worse when the computer runs out of battery and goes into “deep sleep”, meaning the ram contents get written to HD and then most hardware is hut off. Some computers need time to reload the VM file from disk and are already up before this file is completely read. Again, enough timing problem for some audio/video hardware to trip up. In fact, my RME is rock solid, but it is the one condition on my MB Pro that the FW connection doesn’t survive. It needs replugging to work again. Fortunately, there is a big red led on the box.

Some info:,21896.html

Did you try


Thanks to all for ideas and help, especially cyrano. As long as I kept the computer from going into sleep mode by opening other windows, checking email, etc. Audacity continued to record the entire sequence without a glitch.

Have you set Windows not to sleep the computer in the Power Settings?


You’re welcome!

Let’s hope Apple fixes this big pile of bugs in El Capitan.

Since Lion, apple’s reliability has been in the clouds. Everything needs to be iClouded, sent to Apple servers for backup and proxy. After all, you wouldn’t want to type in that password from your Mac again on your iPhone, wouldn’t you? :imp:

And this sleep issue is of the same magnitude. A large part of it is an Intel bug, but all Intel customers have to sign an agreement that they won’t expect Intel to fix any bugs in existing hardware, so we’re stuck with it…

It’s a bit sad, really, that now that we have long enough battery life to record all day with a Macbook, we have to babysit it and keep it from falling asleep. :mrgreen:

You will find helpful tips at the following pages:
5 Tools to Prevent Windows From Sleeping or Turning Off the Display
Sleep Preventer

The Audacity developers might find the tip at SetThreadExecutionState function helpful too.


Oww… Let’s hope Microsoft will deliver the workaround, in this case :blush:

Just some more info, for people interested in the number of “sleep states” a computer has these days:

I’ts a tad bit more than we ourselves have. And it is the C3 or S3 state that is causing most of the sleep related bugs on affected hardware.