Recording Desktop Audio With USB Headset Error

So some basic details first, I’m using a USB headset as my only sound device, so “stereo mix” is not an option as the sound card doesn’t actually process anything. Using latest drivers for the headset as well as Audacity 2.1.0

In Audacity I’ve switched to WASAPI recording and set the input to “speakers (logitech G35 headset) (loopback)” which is what the tutorial mentions for such a situation. The problem however is i get an error popup when trying to record “Error while opening sound device. Please check the recording device settings and the project sample rate.” I used open broadcaster to verify that it can access the desktop audio and sure enough it worked fine, so unless the 2 programs hook differently I’m at a loss for what to do.

I’m guessing it has something to do with this, the device info page acts like it has no supported Rates, it’s saying device 11 is my recording (the one shown). So is this an issue I can fix?
device info.jpg

It’s always shaky when you involve WASAPI, Stereo-Mix or other Loopback application. You tend to lose control of the sound pathways or even understand where they are most of the time.

That can leave you with: “How come I get an echo” complaints.

Sometimes you can’t get a headset to work. If the only way to tame a headset is to use custom ASIO drivers, for example, you may be out of luck because Audacity doesn’t directly support ASIO.

Anything from the headset maker?

As a first pass, I think I would reset Audacity Preferences for Mono, 44100, 16-bit. I have two usb devices that insist on a setting like that to work.

Audacity > Edit > Preferences > Devices and then Quality.

Also remember to start Audacity after you plug the headset in. Audacity goes looking for devices when it starts. You can also use Transport > Rescan…


Tried the settings you suggested and still having the issue. The biggest issue I’m having is logitech bundles all the drivers together for their “gaming products” so the same program you’d use for their fancy keyboards and mice are what you can (very poorly) control the headset with. I may just go pick up a cheap headset to plugin so i can use stereo mix, because at this point I dont even know how OBS is actually managing to get the loopback to work since I cant get it to work in any other programs.

If you plug in a cheap analog headset, you won’t need stereo mix. Just straight recording the mono Mic-In.

You only need Stereo Mix when the computer is originating the show as in YouTube or on-line content. Not if you’re making the show yourself, externally to the machine, such as a microphone.


You could try turning off Transport > Overdub… and Transport > Software Playthrough in the Audacity menus (the latter should never be on when recording computer playback).

Have you looked in the settings in Windows Sound Right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the Logitech headset then choose “Properties”. Then click the “Advanced” tab. Try unchecking the “Exclusive Mode” boxes then set “Default format” to 1 channel, 16-bit 44100 Hz.

Alternatively put checkmarks in the “Exclusive Mode” boxes (whence the “Default Format” choice should in theory be ignored) but ensure you choose 44100 Hz project rate and mono recording in Audacity.


The mic itself works fine, sorry for any confusion. What I’m having issues with is trying to record the loopback to capture desktop sound as well. Basically how I’ve got it setup is 1 track is voice commentary, 1 is audio from the desktop (or game in this case) so I can edit them independently for levels and removing protected music from the game’s audio.

So what application is currently recording the mic?


I use audacity for the mic recording, but I do it after the initial recording as a commentary type thing, so it’s done by itself and is working fine, it’s just getting the loopback to work that I’m struggling with

You could put the original sound track in Audacity and record the commentary as an Overdubbing session. That gives you two different but linked tracks that you can use for post production later any way you wish. The original plays in your ear as you comment, similar to adding the guitar track live while the rest of the song is playing in your ears.

I don’t know that recording two different things in Audacity is going to be an easy lift. It isn’t so far.


So did you try these suggestions?


What I could yes, though under recording devices is only the mic for the headset I did turn off exclusive mode for it and the headset under playback, as well as ensured they were both 16bit, 44100 hz. One thing it seems the post is assuming is it’s an issue with the mic, but what I’m having the problem with is the loopback function (picking up what goes thru the speakers) when using a USB headset. For now I’ve just gone back to using my old headset when i record game audio, it’s not an ideal solution but it seems to be the only one at this point in time.

OK. What about ensuring no other application is using the USB headset, enabling both exclusive mode checkboxes for that headset under playback and recording, then making sure Audacity project rate is 44100 Hz with Transport > Overdub and Software Playthrough off?

Actually I fully understand that - my suggestions were targeted at that, but it’s still better to have both playback and recording at the same settings.