Recording delay during voice pause between talking

I regularly record voice tracks. Historically, I’ve used Audacity 2.0.3 on Windows XP with a 12 year old headset/mic. Recording quality was fine, except for 2-3 blank-outs per track, typically not more than one word lost per blank-out. Annoying during playback, but bearable for my non-commercial needs. (I believe the blank-outs were caused by insufficient computing power.)

I bought a much more powerful computer, upgraded to Windows 8.1, Audacity 2.0.5., and a Logitech h150 headset/mic. I’m no longer experiencing the blank out issue.

However, I’m now having a worse, non-bearable issue, which seems to be twofold:

  1. There is a considerable delay between when my voice hits the mic, and when Audacity seems to be receiving the sound. This is visually apparent by watching the vertical range scale while recording. I would estimate the delay to be between .5-1 second.
  2. If #1 only happened at the beginning of a track, I could live with it. However, every time there’s a brief pause in my voice, like between sentences or when taking a breath, Audacity seems to stop or pause recording. When I again speak, two things happen: a) the delay from #1 kicks in, and b) when the recording finally picks up my voice, the playback sound is only at roughly half volume for roughly .5-1 second, before it plays at full volume.

The combination of 1 and 2 create an nonviable result.

I’ve read several posts in this forum regarding latency that seem to come close to this issue, but don’t seem exactly on point. (Of course I could be wrong about that.)

Overdub: off
Software play through: off
Latency: 100
Latency correction: -130
Sound activated recording: off

I was eager to finally use Audacity with more computing power to be rid of the blank-outs, but now I’m stuck with this new issue. Thanks for any help.

Are you running any other programs in the background?

If it’s not sound activated recording, I have no idea what the problem is. But, it’s not latency…

A large buffer (and the accociated longer latency) are generally a good thing, because it allows your CPU & data bus to do other things for a longer period of time before you get a glitch caused by buffer overflow (or underflow on playback). With a multitasking operating system, the computer is always doing things in the background, so you need a buffer (and a buffer is a delay).

Latency ONLY becomes an issue when you are monitoring yourself through headphones, and the delay makes it difficult for you to speak/sing/perform.

Latency correction is ONLY important if you are trying to record and synchronize with a backing track.

Otherwise, there can be minutes or hours (or years) between the time you record & play-back, and a short recording (or playback) delay is of no consequence.

Logitech h150

That’s an analog mic, right? Two 1/8" plugs?

As above, Voice Activated Recording is usually the culprit here.

See if you can make a recording in Windows Sound Recorder.

  • Windows Sound Recorder
  • Start > Programs > Accessories > Entertainment

Just a fuzzy, background idea… Check if Windows Enhanced Services is running.

I don’t have a shortcut for this. It’s in Windows Control Panels.

Windows comes right out of the box ready for Skype and other conferencing systems. It says so in the web page for your headset.

Easy setup
Just plug your headset into the 3.5 mm input and output jacks on your computer and it’s ready to go. Simple as that.

I wouldn’t be shocked if Windows is trying to mute your microphone when it thinks you’re not using it. Once easy way to do that is to halt the bitstream. That’s effective, but it will drive Audacity nuts.


Do you use Skype? If so, your microphone might be filtering itself through Skype processing before Audacity gets to it. Apparently Skype isn’t so easy to turn off. There’s a Dilbert comic about it.


Koz brings-up a good question… Is it a timing pause? i.e. Does the recording actually pause, like when you pause a cassette recorder or video camera during recording, so that a 1-minute recording turns-out less than 1-minute when you play it back?

Or, is it an audio drop-out, where the recording-time continues, but your voice is muted for a short time?

I’m only running Firefox in the background. I agree with you that latency is likely not the issue.

Yes, analog mic.

Sound Activated Recording turned off.

Yes, able to make a recording in Windows Sound Recorder. Having the same issue though, only far LESS pronounced. The recording delay only kicks in after much longer voice pause, like one full second vs the space between sentences. Then when it finally plays back the voice on the other side of the delay, rather than playing it at half volume, it clips the first word or so, but at normal volume.

I searched high and low for Windows Enhanced Services, but couldn’t find it. However, in Task Manager, there is a long list of services in the ‘Services’ tab, though none of them specifically labeled as ‘enhanced.’ A few of them look like potential suspects for this issue, though I don’t know how I might tell from just the list.

Your idea about Skype seems sound. I closed Skype in the Task Manager. I also disabled Skype under the ‘Startup’ tab in the Task Manager. I then tested voice recording. That changed the texture of the issue, so it clearly did something, but it didn’t change it enough to have a meaningful impact.

“I wouldn’t be shocked if Windows is trying to mute your microphone when it thinks you’re not using it.” This seems like what’s happening, but I don’t know how to locate and stop that process in Windows. (Again, closing Skype didn’t resolve the issue.)

Timing pause vs audio drop-out: definitely seems to be a audio drop-out, per your definition. This is confirmed visually by watching the recording line play back across the vertical range scale. The recording is not ‘paused’ time-wise, only ‘muted’ sound-wise.

Leave Skype off and not automatically starting up (you can manually start it when you need it and shut it down again when your finished). It sounds like this has helped a bit, though not enough.

Try making a recording with the Task Manager open, and keep an eye on CPU usage and Disk Access. If either of these are very high, that could account for the problem.

This FAQ tells you how to access the “Enhanced” sound settings:


I restarted the computer and confirmed in Task Manager that Skype is no longer running upon startup. With Task Manager open, but no other programs running, I performed a recording test while watching the CPU Usage, Memory Usage and Disk Access. The draw on these resources was negligible. Same problem, no improvement.

I’d previously covered all the points in the link you provided, but I double checked them again to be sure. I was unable to locate any of these setting options in the Sound/Recording/Playback menus: Noise Suppression, Echo Cancellation, Environment. There was one option in the Sound menus, under Communications, that read: ‘When Windows detects communication activity:’ –Mute all other sounds, +Reduce volume of other sounds by 80%, –Reduce volume of other sounds by 50%, –Do nothing. The second option was pre-selected. I changed it to ‘Do nothing’ and ran a recording test. No improvement.

To be sure I wasn’t missing them somewhere, I then globally searched my system for Noise Suppression, Echo Cancellation, and Environment, but they don’t appear to exist in my system. There is an ‘Environment’ as it relates to System Properties, but nothing in those menus had to do with sound.

Some sound cards have their own control panel. In some cases the sound card’s control panel will override the Windows Sounds settings. Have a look in the Windows Control Panel (“Classic View” is easiest, if Windows still has that) and look to see if you can find a utility for controlling/configuring your sound card.

Have you told us what sort of sound card you are using?

Thank you everyone for all your help. Much appreciated. An update:

After spending most of 11/7 testing every conceivable configuration of settings and volumes per your various suggestions, and then some, I called Microsoft support. The tech told me that they are receiving a ton of phone calls right now concerning 8.1 incompatibility issues with third party applications and hardware. They are recommending that users get the 8.1 updates from app/hardware manufacturers when they become available, or revert to 8.0 until such time.

So, I’m just going to continue Audacity recording on my XP machine until Audacity releases an update for 8.1. Not ideal, but totally workable.

Thanks, again.