recording creative soundblaster and input level

Audacity 2.0.6, windows 7 ultimate 64-bit,
soundblaster X-Fi XGamer7.1 sound card.

often i’ll record audio played from my browser, such as a song from youtube, and export it as mp3.
problem i have is getting the volume of the recording correct.
for Audio host, I can choose from MME, Windows DirectSound, or Windows WASAPI. I use MME currently.
for playback device, i have set to "Speakers (Creative SB X-Fi).
for input I use "What U hear (Creative SB X-Fi), but i can also choose from Microsoft Sound mapper input, the others like microphone or line in are not relevant

Using MME and What U Hear, I have to set recording volume at 0.20 or less. Anything higher than 0.30 i get clipping.
My question is, how do you set audacity up to do what i’m doing and have the recording playback volume correct, such that if i’m playing the song on the computer through the browser it’s playing at some volume level through my speakers. After i record it and play the recording through Audacity, i want the volume coming out of my speakers to be the same.

Then play the audio more quietly. If there is some boost control for What U Hear in the SoundBlaster control panel, turn the boost off.

You can’t have the recorded level turn out to be apparently the same as the level of what you were playing in the speakers, other than by experimentation with the recording level and the playback level.

If you want make it easier to avoid clipping, choose Windows WASAPI and the loopback recording device. The recording level is then managed automatically - the level you choose on the Audacity Recording Volume slider won’t affect the level you record at.

Obviously if you want the level of the original streamed file to be the same as it always was, don’t record it at all - download the file. That way you won’t get any Digital > Analogue > Digital conversion loss and you won’t get system dings in the recording. :wink:


i understand about downloading the file, i some times do that but if it’s a movie or video and I just want the audio it becomes a little tedious with vlc. I prefer to use audacity, and it’s not just music files many times i’m grabbing sound bites from here and there in the middle of some large audio/video playback.

I’ve tried using WASAPI and loopback but audacity gives me an error. right now it seems the best way to get it done is with MME and what u hear.
Any other combination of options that do work results in a very faint recording with the input volume in audacity set to 1.0, then i do normalize and it brings the volume up but it is still reduced in the recording vs the original.

by the speaker volume i meant… say i play some audio/video file on my computer using IE or firefox it sounds as loud as it does coming out of my speakers, and it sounds good.
without touching speaker volume or any other computer setting, if i then use audacity to record it with whatever settings and export it as mp3 that newly recorded file comes out of the speakers at a reduced level. To me that tells me there is some conversion or something happening where i have some settings incorrect somewhere. with any other settings besides MME & what u hear the recording level is so low that the waveform in audacity is practically a straight line until i normalize it afterward and then i can hear that the recorded file has a reduced volume to it. hope that makes sense.
what does make sense is an audio output boost setting somewhere within Creative Soundblaster, I’m pretty sure nothing like that is set. I know all audio effects are turned off, but i’ll look harder. thanks.

If you want the whole audio it is still better to download the video file. Install FFmpeg then drag the downloaded video file into Audacity - Audacity will then import the audio for you.

That should be correctable assuming SoundBlaster can work with WASAPI. Use 44100 Hz project rate (bottom left of Audacity). Play the stream before starting to record.

If you still error, try going into Windows Sound, click “Playback”, double-click the SoundBlaster device, then click the “Advanced” tab. If both “Exclusive Mode” boxes are checked (ticked), try unchecking them then set the Default Format above the boxes to 44100 Hz. Then restart Audacity.

I thought you were complaining the recordings were too loud? With What U Hear you can adjust the recording and playback level and/or Normalize afterwards so that it is at the level you want before you export. If it still does not sound loud enough you can use Effect > Compressor… to reduce the dynamic range, but that should not be necessary.

There are inevitably conversions between digital > analogue > digital if you prefer to use What U Hear. If you can use WASAPI loopback it is entirely digital, but you still cannot guarantee the recording will sound as loud as it was originally.

MP3 is lossy and may reduce or increase the peak level so you are getting even farther from the original.