Recording computer playback without stereo mix [SOLVED]

I just upgraded to Windows 10 from Windows 8/8.1 and I can no longer get Audacity to record in any format. I am currently using a Dell Inspiron 660 w Intel(R) Core™ i5-3330 CPU @ 3.00GHz. Included is NVIDIA High Definition Audio. I’ve gone to the Dell Website and upgraded all my drivers to no avail. I’ve also followed the instructions regarding my sound devices & have changed the setting several times (disabling my line in and microphone settings), however I do not have a “stereo-mix” option. Also, I am not receiving any error messages aka “could not find any audio devices” / “Internal PortAudio error.” Any ideas or can someone point me in the right direction? All help appreciated.

If you have the Conexant audio driver listed on then you have the best driver available for your machine running Windows 10. However there is no rule that says that driver gives you stereo mix. Manufacturers are increasingly dropping stereo mix due to concerns over copyright material bein recorded.

If you had received the “Internal PortAudio Error” then disabling built-in inputs might have helped, but you don’t have that error.

Fortunately you don’t need stereo mix to record computer playback - you can use the Windows WASAPI (loopback) method instead as described here: Using that method, you don’t need to disable line-in and microphone, so go ahead and re-enable those if you need them.


Thank you for your help! It worked like a charm! The only thing that comes up now is “Stereo Mix” on the recording devices and that works perfect for what I need! Thanks again!