Recording clipping at 0.5 (-6 dB)

A have Audacity 2.2.1 on Ubuntu 18.04.
Any recording (from a microphone) is clipped at 0.5 (-6 dB).
I found many mentions of this question on the internet, but no answer, back to 10 years ago.
I could not find anything in the settings to change this.
Recording in mono or stereo does not change anything.
I have seen this for some time now, but I never had this problem on the previous versions. Previously, the waveform would use the whole range.
Thanks for your advice on that matter.

What sort of microphone are you using, and how is it attached to your computer?

Is it clipping at exactly -6 dB? (If you select the track and open the “Amplify” effect, it will tell you how much amplification is required to bring the peak level up to 0 dB)

I am on Manjaro-Linux, therefore each software is always at the latest revision. On my Audacity, I can watch the same effect, that the signal is clipping at -6db precise.
I have found, that this is the case only, when using analog microphones at the computer’s mic input. If I record from internal audio output or via a so called USB-microphone, I can get up to zero db or above.

Perhaps it is a problem with the hardware / mic preamp of the mainboard? I am on an ASUS Z170.

I am interested in a solution of this.

Is this a laptop computer or a full-size desktop / tower?

If it is a laptop, do you have separate sockets for microphone and headphones?
If it is full-size PC, are the sound card sockets color coded?

To follow up with this question, I can specify: for some time now, recording is ALWAYS clipped at EXCACTLY 0.5 (- 6 db) on my version of Audacity in Ubuntu. It was there with 2.2.1, now I upgraded to 2.3.3, and it is exactly the same. I also have Windows on my double-boot computer, and the Windows version does not clip recording.
I tried to delete configuration files, this does not change anything.
I am using an external microphone (as the internal one is out of ordre), but this cannot be the reason. Recording with another tool does not result in clipping.
I found a number of old mentions of this clipping problem in old posts, none of them mentioning any relevant information.

Do you have Linux set to record internet sound? Depending on configuration, what that actually does is add all your sound sources up and records everything. If your built-in microphone is dead, that may reduce available analog volume by 6dB.

A more normal reason for this reduction is recording a stereo show in mono. In order to make room, the system reduces everything by half, 6dB. This reduction can happen anywhere in the system. It doesn’t have to be Audacity. It’s also a little wacky. Having two tracks is no guarantee you have stereo. Are the two tracks different? If they’re not, then what you really have is two-track mono.

Audacity doesn’t apply filters, effects, or corrections to a recording. It gets the sound from the operating system not the device. That’s why it changed when you changed OS’s.

If none of these is applicable, post back.


Thanks for your answer.
The situation is as follows :
If I record using the internal microphone which is out-of-order, I do get som sound : a rumbling sound (ampitude like 0.02, base frequency seems to be 50 Hz), plus a bit of speech at a very week volume… not more than the backgounr noise.

  • With the external microphone on the jack, the background noise disappear. So it seems that the connexion in the jack entry automatically disconnect this internel microphone.

  • The sound wave is clipped at 0.5, whatever I do it in mono or stereo (and in stereo I get two identical waves).

  • As for the setup to record internet sound, I did install audio-recorder some time ago, hoping to be able to do that (audio-recorder). But I do not see any setting about this channel, and it is setup to use a microphone. Should I try to uninstall it ?

  • I tried to check things with alsamixer, but I do not see what woul be related to it and I do not know how to access this setup.

I get this problem if I plug a SoundBlaster computer mic into the mic input socket. The problem (in my case, and it sounds as if it’s the same for you) is that the audio input is wired for stereo input, and the wiring of the mic is incompatible. There is no “solution” to this problem other than using different hardware, but there is a “workaround”.

The workaround is to reduce the mic level, and increase the recording level (see images below).
This workaround is far from perfect because the mic input on my laptop is rubbish, and the noise level is high.

For serious recording work I “fix” the problem properly, by using a better mic and a better mic pre-amp.

Thanks for the detailed answer. It is likely to be the explanation.
I do not have a stereo microphone to test (I do have a external stereo recorder device, but I do not think I can plug it into the computer). If I find such a microphone, I will test it with Audacity.
For the time being, it is not a ibg problem for me. I can easily amplify the sound if necessary (we just loose 6 db of dynamic, if it is what the name is in English - my language is French, but for ordinary speech recoprding, this is quite ok).