Recording cassettes doesn't work

I’m trying to record a bunch of old compact cassettes using a device called SUPER USB CASSETTE CAPTURE. It’s one of those generic ones I’ve bought on Amazon. I’ve connected it using the official Apple USB-A to USB-C adapter on my 2018 MacBook Pro as it came with a Mini-B to USB-A cable.

In System Preferences and Audio MIDI Setup it randomly shows up for a second or two and then disconnects for another 5 until it reappears again and so on. I did manage to connect it to Audacity after some trial and error where it shows up as USB PnP Audio Device, however it won’t record as there’s an Error opening recording device with Error code: -9997 Invalid sample rate. I’ve tried using different sample rates but none of them work.

I did manage to somehow get it to record before (not sure how) but Audacity just randomly stopped recording after about 11 minutes for no apparent reason so I then tried using my old 2012 MacBook Pro if it would be any different on there but nope, same issue as above except with Error code: -9986 Internal PortAudio error. I’ve now reconnected it to my 2018 MacBook Pro but now I’m back to square one. This is just beyond ridiculous and frustrating!

I’m using Audacity 2.4.2 on macOS 10.15.5.

It shows up as a “PnP USB Audio Device” right? I don’t know anyone who has got one of those to work reliably on Mac.

– Bill

What do you suggest? Should I try it in a virtual machine running Linux?

What do you suggest? Should I try it in a virtual machine running Linux?

If you’ve already got Linux running it’s worth a try. Otherwise, it’s probably not worth the effort.

Another possibility is a USB audio interface with line-inputs (connected to the cassette player’s headphone-out). Or, you can use an interface if you have an older stereo with a cassette player you can use that (with line-output, recording-output, headphone-output, etc.).

There are a few suggestions on [u]this page[/u] or there are lots of higher-end interfaces with switchable mic/line inputs. Do NOT buy a regular little “USB soundcard”. They are like laptops with only mic-in and headphone-out.

I don’t know anyone who has got one of those to work reliably on Mac.

From what I see on the forum they are often flaky on a PC too… I doubt they are 100% reliable on Linux.

Hmm, I do have a FiiO Q1 Mark II DAC/headphone amp, would it be possible to use a 3.5mm to 3.5mm aux cable to connect it on there? Would that work?

I do have a FiiO Q1 Mark II DAC/headphone amp,

No… You need an ADC, not a DAC. :wink:

How would that setup work?

If you were using the [u]Berhinger UCA202 interface[/u] the headphone output from the cassette player goes to the analog inputs on the interface (with appropriate cables/adapters) and the interface connects to the computer via USB.

An interface is similar to a soundcard. It has an ADC for recording and a DAC for playback.

Hmm, it seems like that one isn’t available here unless I import it which would be rather expensive and time consuming. I’ve found this one on Amazon though: Would that one work? Also on Mac? Even with the USB-A to C adapter, would that cause any issues?

The description says it works with macOS. I can’t guarantee anything, though, having never used it.
– Bill

It works! :smiley:

Now there’s just an issue with me having hundreds of dropouts. They’re barely noticeable but still. How do I prevent those from happening?

First, make sure the USB device is connected directly to the Mac, not through a hub.

For the dropouts, look through the suggestions on this manual page.

– Bill

Well it’s impossible to connect it directly to my Mac as it doesn’t have any USB-A ports but at least it’s not a hub with multiple ports.

I’ve now set buffer length to 0 and turned software playthrough off. (I have to leave auto-scroll on though as I need to know when to stop recording) That definitely helped but about an hour into the recording dropouts start to occur once again. I’ve got no other applications open, I don’t use anti-virus software, Audacity is always in the foreground, I always install the latest updates and I’ve got a Core i9 processor and 32GB of RAM so that’s not the issue either.

You can zoom out so that Audacity doesn’t need to scroll but leave auto-scrolling on. You can still see when the recording ends. Try turning software playthrough back on. Buffer length of zero is weird. Try 20 to 50.

If dropouts occur after an hour, can you record in chunks of less than an hour?

When you create a new project, immediately save it to your usual location. This avoids using the temp directory.

The USB-C adapter shouldn’t be an issue.

– Bill

I had a feeling that perhaps some of the background apps that Adobe forces down your throat (as you can’t remove them from autostart) may consume some resources so I force quitted them in Activity Monitor which seems to have fixed the issue of dropouts. I still get them sometimes but only 1 or 2 in the very beginning before the audio starts kicking in so it doesn’t matter there.

Ah, don’t we all love Adobe! (Not!)

Yes, I sometimes get a couple of dropouts detected at the very beginning of a recording. In some cases they are before time zero, which is weird.

– Bill