Recording audio from sound card

Occasionally I want to record sound (spoken word or music) that internet sends into my computer and which is audible from the sound card. I use Audacity 2.05. Which settings do I use?

I use the dutch version, my inputbutton only shows “Microsoft geluidstoewijzing - Input” “Microfoon (Logitech USB Headset)” and “Microfoon (USB Audio CODEC)”. I have tried all three options, no result.
I also tried “Audio host” MME, Windows direct sound and Windows WASAPI. Using WASAPI I do get the required signal but I can’t adjust the volume, it’s far too loud and distorted. I see no other options where I can record from the sound card.

Best regards,

We don’t make a “2.05” version so the first step is to uninstall “2.05” then install the official 2.0.5 version from .

There is no Dutch version of Audacity, although if your computer is running in Dutch, Audacity will run in Dutch. Please install Audacity from the link above.

Windows has disabled all your built-in sound card inputs or you have disabled the built-in sound card. I suggest you follow . Show all the disabled devices then enable them all. If you see stereo mix or what U hear, make that device default device.

Stereo mix or what U hear cannot record from a USB headset. So remove your USB headset, restart Audacity and choose stereo mix or what U hear as the input device. Play the song you want to record through the computer speakers then stereo mix or what U hear should record it.

WASAPI (loopback) is the only input that can record from your USB headset. If you require to play your song through the headset, choose the Logitech USB Headset for output device and Logitech USB Headset (loopback) for input device.

You can’t adjust the input level in Audacity using WASAPI loopback but you can turn the song’s volume down in the web browser flash player. Make sure Audacity Project Rate bottom left is at 44100 Hz.


First of all, I use version 2.0.5; I just missed one dot. I have downloaded Audacity from the official website. So I use the correct programm. My version uses Dutch texts, I can’t know whether that’s only Dutch words or a Dutch version. If I can choose a language, why is there no Dutch manual available? Many descriptions in the English manual are very difficult to understand; and you have to be an IT specialist to understand the manual.
But anyway, that’s not my point. I have used the link you mention ( . ) and followed the intruction. I have tried to find out which recording devices are installed; it only gives two microphones, Conexant SmartAudio HD (diabled) and USB AudioCodec (USB) (enabled). I presume the USB is an external audio device because I am currently recording my LP’s. But that’s all there is, only two microphones. No sound card. Yet, when I use my headphones (or unplug them) I can hear internet sound from my sound card. So my sound card is okay, but apparently it’s not connected as a device where I can record from.
So now I still don’t see how to make the sound card to be one of the recording devices.

I have also tried to record with WASAPI (where I do get sound from the sound card), but I don’t know how to reduce the volume of the incoming sound. When playing ome music from Youtube, I don’t know whether I use any flash player or anything else, there is just sound coming from the peakers in my laptop. So I tried the little speaker icon in the bottom right of my screen and reduced the volume to only 20 %, but then I can’t hear the sound that I’m recording any more, yet the recording itself is very distorted! In WASAPI I can’t control the volume of sound that has te be recorded.

Any suggestions?

Thanks in advance!

Problem solved: I can easily use WASAPI for recording streaming audio from my sound card, but in order to avoid the distortion I only had to switch off the “Playthrough” option under “Preferences” - “Recording” menu.
That;s all!

Thanks for all help!

Because there are no volunteers who are prepared to translate the Audacity Manual to Dutch.

Sorry but for native English speakers I can’t agree with you. But if something is really bad about the Manual in your opinion, let us know.

Conxeant is the microphone of your built-in sound card, but that microphone input device is disabled. If you want to sing or speak into the microphone you must right-click over the Conexant microphone and choose “Enable”.

Good. Thanks. :wink: Software Playthrough is not on by default but you must turn it off when recording computer playback by any method.


Yesterday I was able to record streaming audio in Audacity. (See former posts) Without changing any settings, today it suddenly didn’t work. After pressing the red “record” button, the cursorline does not move and I get a message that the sound input devide is wrong. With exactly the same settings, yesterday it went well!!

I wonder what goes wrong this time…

Recording my LP’s to mp3 files is the only thing that I manage to do with Audacity. Or editing existing mp3 files. Why is it so difficult to just record streaming audio?

Obviously we can’t see your computer but make sure the Audacity project rate bottom left is 44100 Hz.

Make sure no other application is already recording from the sound device when you start to record in Audacity.

Have you changed the device you are using to listen - for example, are you using headphones instead of speakers? If so, you must change the playback device in Audacity Device Toolbar to that playback device and you must change the input device in Device Toolbar to the (loopback) option for that same playback device.

Where are you playing the song? In a web browser? Have you changed the application in which you are playing the song? If the application playing the song demands exclusive access to the sound card, WASAPI cannot record from it.

Otherwise, restart the computer if the problem persists.