Recording (and play) stops immediately because of unknown setting?

I’m running Audacity v.2.3.3on Ubuntu Studio.
I’ve made several successful recordings recently, but sometimes, in the middle of everything working, I will try to record, a second track over a backing track, and when I hit record the buttons flash and it starts, but then the record process stops immediately, or after a second.
I’m thinking there is some setting that is accidentally tripped, perhaps on the time line. I keep fooling with stuff and sometimes the problem stops, but right now I can’t get it going. This also seems to happen on record. I have spent over an hour fooling with this and it’s keeping me from a lot of music.

I plan on RTFM, have looked around, and searched the web, but found no solution. I want to learn a lot about Audacity, but right now I’d be delighted to solve this one mystery and record my guitar track, and know what to do next time.


Check that you’ve not enabled “Sound Activated Recording” (it should be off / unselected)
“Transport menu > Transport Options > Sound Activated Recording (on / off)”

Hi, Steve,
No, “sound activated recording” was not on, but going to that menu area showed me that “software playthrough” was, and recording worked when I de-selected that. But I can’t hear my guitar (plugged directly into a usb interface) through the headphones, which was why I turned “software playthrough” on. I am able to record the second track now, hearing the backing, but with no live signal in headphones. This happened to me before, when I had not clicked that, so I might have this problem again. If so, I’ll post here again. Thanks!

If you can tell me, what’s the simple way to hear your live input while recording a track. Thanks!

Your headphones should be plugged into the USB interface. Most USB interfaces will then allow you to monitor the input, even without any software running.

Another thing that might be causing it is a bug (I guess) in how Audacity interacts with PulseAudio, if your setup uses PulseAudio.

I was helped by this thread: Recording stops immediately in overdubbing mode, not always - Audacity Forum. Basically you bypass it by selecting specific recording and playback devices, not ‘pulse’ or ‘default’.