recorded vocals break up, sound tinny, and phased

:question: When I overdub vocals to a backing track, they break up, sound like they were recorded in a barrel, and have a broad “phasing” quality. I am not running any other programs, and have a lot of hard drive capacity open. In preferences, I’ve changed audio to buffer to 10 MS, and use hardware playthrough. The problem isn’t as bad if I mute the backing track, but it’s still there. It doesn’t break up as badly, but the phasing is still there, as is the tinny quality.
The project rate is 44100 Hz. I’ve tried lowering playback volume of the backing track to almost nothing, and disabled the meter for the mic. I’ve also changed the refresh rate on the playback to only once per second. Changing the mic recording volume doesn’t change anything. I’m using a ProLogic headset/mic through the USB, and am recording to one (mono) channel.
This problem just started recently, and I don’t know why, since I hadn’t changed any settings. I’ve been able to record up to 20 tracks with no problem, but now, I can’t even put one down.
CPU usage shows pretty low when I’m recording, too.
The problem isn’t in the mic, as other programs record my voice just fine, including while overdubbing.

I’m running Mac OS 10.9.5, and Audacity 2.1.2

and use hardware playthrough.

Did you change any applications or tasks? I think it’s still true that OS-X does not support Hardware Playthrough, so wherever you think you’re getting your sound from is probably not correct. Do you hear your own voice in your headphones without an echo? I believe you’re not supposed to be hearing your own voice.

Did you just start using Skype or other communications or conferencing program? Have you just started to record on-line content through SoundFlower or other program?

I wrote the original overdubbing tutorial and I started the journey by making a plain, ordinary, unexciting sound recording. If you can’t do that, then overdubbing is just going to dig you deeper and deeper.

Audacity > Preferences > Recording: De-select everything. No [X] on that panel > OK.

Now press Record to make a test sound recording. Use the bouncing sound meters to guide you; you won’t hear anything. Record and Playback are handled as two separate tasks. Being able to do one does not guarantee you will be able to do the other.

Stop and play that back. Does it sound normal?

If you can hear yourself during the recording, that’s not normal and there is a rogue sound pathway somewhere.


Koz - thanks for the quick response.
I deselected everything under recording preferences, and the recording was fine. I have never been able to hear my own voice through the headphones, by the way. In the past, I’ve always heard the backing track in the headphones. Of course, with everything deselected, I now can’t hear the backing track, or anything else, so that’s not an option.

I have used Skype forever, never had a problem before, and haven’t made any changes. I do record with Audio Hijack Pro, with the recording settings set for streaming online music. However, I’ve used that for a long time too, without problems spilling over into Audacity. And neither Skype or Audio Hijack Pro are open and running when I’m recording. In fact, nothing else is open at all.

I tried setting Audacity output to the computer speakers rather than the headphones, and that was a slight improvement, but there is still a little bit of a phaser/flanger effect, and the recorded vocals occasionally sometimes suddenly drop momentarily in volume, like it was clipping, but it’s not. Then, with the external speakers being used, I get that sound being picked up by the mic, too.

As mentioned, I can overdub vocals in Garageband, with none of these problems, so interference with preferences from an outside program doesn’t seem likely.

Any other ideas?

Are you sure?

I think Prologic is a Dolby trademarked brand. And I think they don’t make USB headphones.

Just in case the Mac is doing the phasing, see “On Mac OS X” here:


In the past, I’ve always heard the backing track in the headphones.

OK. Baby steps.

Now go back in and turn [X] Overdubbing on > OK.

Make a test recording. I expect a clean performance and you to be able to hear the backing track. Do Not turn anything else on. Does your live performance recording sound funny? Does any part of the backing track appear in the live recording?

What does your microphone look like in the Audacity record setting (next to the microphone symbol)? USB devices tend to have magic names and there isn’t any standard I know of. My stereo interface appears as “USB Audio CODEC.” That’s the name of the software, not its name or the maker.


As a fuzzy rule, you can get your symptoms by having the computer try to apply echo and noise reduction in real time (like a cellphone), or having multiple uncontrolled sound pathways fighting each other (feedback or bad mixing). Cellphone processing hates music.

It’s fascinating that running your live speakers instead of headphones makes the problem better. That’s the exact reverse of expected behavior.


Cyrano and Koz - oops, the headphones are LogiTech, and they show up as Conexant USB Audio. Not a good mic, but it’s what I’ve got right now.
Gale - I went to Mac OS Preferences, and the “Use ambient noise reduction” option is unchecked.

Koz - only the overdub option is checked, with audio to buffer at 10 ms and latency correction at -125 ms. Did all you suggested, with the same results. Playback of the backing track is not being picked up by the mic. Any suggestions as to what I might check on the laptop regarding realtime noise reduction?

Here’s a short clip of the result I got:!4ZwhmR7R!0K6m9TzQZhRA_GFPW2NvuxdpXSCD_EMqVa-qOVA_ZTQ

Remember, the vocals record OK in other software. I tried removing the backing track and recording the lead vocal over the exact same lead vocal clip, at all volumes of recording and playback. Still the same.


Sorry, you need Flash to work this service.
Sorry, Safari is not supported.
Sorry, you need to download and install Mega to use this site.

Since we don’t need surgical precision for this particular test, drag-select a one minute representative chunk of mono sound, Export Select it at 128 Quality MP3 and post it here on the forum. That should give you a 1 MB file which should fit nicely. If you do it in stereo, it may expand to about 2MB and very close to the forum limit.


headphones are LogiTech

Closer. If you have microphone and headphones on the same band that goes over your head, that’s a headset. A matching set of microphone and headphones.

Let’s take this a slightly different way. Is this a MacBook, MacBook Pro or MacBook Air? Something with a built-in microphone? Do you have earbuds or regular analog headphones (no microphone)? Unplug your Logitech and set up to overdub with your built-in microphone and regular headphones. You may need to restart Audacity for it to pay attention to the changes.

I know you’re not likely to get any calls from Warner Records recording like this, but those microphones are not completely dreadful and I’d be fascinated to find out if it has the same problem.


Any suggestions as to what I might check on the laptop regarding realtime noise reduction?

No. You found The One, or at least the one that comes with the Mac.