Record streaming audio, not microphone [SOLVED]

I am using Audacity 2.0.5 on a Windows 8 Pro machine and on a Windows 7 Laptop. An acquaintance is using it on a Vista machine. I was telling someone how to record streaming radio with Audacity, I had no problems with my main machine (Win8) She said that there was a lot of noise and hissing when she tried it. Again I had not problem with my main machine. I decided to try it on my laptop (her machine is a laptop, Vista…) and I found the same problems she did. As I played with it I discovered several things. I found the Level controls, and they helped a lot. But I also found something unexpected. I found that some comments I had made during the recording of the stream were in the recording. I realized that the laptop has a microphone, as I had not used it in the past, I did not know it had one :slight_smile: Anyway, apparently this mike is the source of the noise. When I raised the recording level, the recording improved, but if is said anything, it came through loud and clear. Of course, any other source of sound, like a shutting door, would come through as well. I have looked, and looked, there does not seem to be any way to turn off or disable the microphone. If I can figure it out then I can tell her how to do it on her machine. Does anyone have any ideas?? Or do we just turn up the Record level and walk around on tiptoes???


Recording streaming can be an adventure because newer computers make it harder and harder. It’s not a guaranteed service.


Thanks, but there is a misunderstanding here. I can record streaming audio, but I am also recording from a microphone that I did not know was built into the laptop. I have a Win7 Pro, HP laptop. I did not know it had a microphone as I had never tried to record anything before. My desktop is not a problem because I do not have a mike plugged into it. So, does anyone know how to turn off the mike?? Is there some place in Windows that I have not found that can turn off the mike??? Starting with Vista you could control audio outputs individually, but apparently, you cannot control audio inputs individually.

John Waller

Then don’t. Audacity can choose inputs to record from and you have to tell it what input to use. It can’t guess what you want. You tell Audacity the input you want to use in Device Toolbar .

Record from stereo mix (if your sound card has it), otherwise use Windows WASAPI loopback, using the instructions Koz gave you. This is the link: Audacity Manual .


That was what I was trying to find out, and I could not find the answer. Unfortunately, the link that Koz provided did not deal with the issue I was having. I eventually found WASAPI by stumbling around and got my laptop to record as expected. I did find out how to disable my mikes, but then Audacity lost its access to audio, I could not record a thing. This was before I discovered WASAPI. Your link was the first one that led to an answer to my issue. In general, I am a big fan of ebooks for documentation, as you can search them and not be limited to the index the publisher provided. There is one caveat, you have to know what terms the ebook uses so you can search for an answer. If you use the wrong phrase, you will not find an answer. In this case, I had searched the Audacity files, but did not come up with the link you provided. So I had phrased my question wrong…


If you used CTRL + F on the front page of the Manual to search for “streaming” you would have found it at once.

If you were searching for how to disable the microphone, you would not find that very easily because it is not the correct solution to the problem. One may want to record streaming audio on one occasion and a microphone on another occasion.