Record mode not working

I have been using Audacity 2.4.2 with Big Sur 11.1 on my MacBook Pro for weeks successfully to digitally record old vinyls into my Library. Two days ago that suddenly changed. I don’t know whether I accidentally touched something that caused it, but I can’t see anything wrong in Audacity or Mac settings. With a record playing and the turntable connected trough USB-C, as soon as I touch the record button the red line begins to move across the track, not waiting for sound, and there is neither sound not a wave form. If I switch to GarageBand, sound comes through. My settings are Core Audio and Codex USB with MacBook Pro speakers as output. I am able to pull up any saved projects and work with them normally. Also, when I select New, instead of bringing up a track, it brings up a second blank Audacity page. I have already tried re-downloading 2.4.2. ANY SUGGESTIONS?

Try doing a shutdown. Take out the battery. Wait a few minutes and put it back in. Power cord again. Boot up the computer. That resets the SMC memory. See

Check your Settings for the right input outputs showing up.

Try that.

Yes, a couple of things:

  1. To reset your Audacity settings, select Tools > Reset Configuration
  2. To activate sound activated recording, select Transport > Transport Options > Sound Activation Level…, then Transport > Transport Options > Sound Activate Recoding (on/off) should be checked. You can alternatively set the same options in Edit > Preferences > Recording.
  3. Make sure your turntable is plugged in before starting Audacity. Alternately, you can do a Transport > Rescan Devices.

Yes, that is the correct behavior. To start a recording, simply select your recording device, see step 1 here:
then, press the record button.

I hope this helps. :smiley:

Followed your instructions Jademan but didn’t change anything. Sound activated record set at about -56-58 dB. Don’t know what proper level should be. Sound activates recording, checked. Software play through, checked. Are these correct?

Robert, thanks, but not comfortable removing the battery.

OK. Two more things to try (separately):

(1) Check that Audacity has permission to use your device. (In “Apple menu > System Preferences > Security & Privacy”)
(2) Try changing your project rate from 41400 to 48000.

That sounds OK. There is no need to use that feature. It shouldn’t make any difference.

That is fine. This shouldn’t make any difference, either.