Record a stereo signal

Moderator: split from

I am running an HP quad-core laptop that has been updated to Windows 10 from Windows 7. I have done some investigations but still need help with this issue.

My friend introduced me to the iConnex iKey-Audio external card and Audacity. He said it worked great when he captured all of his reel-to-reel taped music to CD’s. To me, his recording sounded like a recording with one channel missing (you can hear the other channel but only as a function of channel separation leaking through and not like a full stereo recording). I didn’t mention it to him. He was happy with his recording and gave me his iConnex box and the Audacity software (which I have since upgraded to 2.1.2).

After two years of sitting in my closet, I finally got out his iConnex box, downloaded the latest version of Audacity and tried it out. I am seeing the same thing on my system that I THOUGHT I was hearing on his recordings, i.e., one channel is missing. If I play a stereo audio source from a player and connect white to white and red to red with a known good set of RCA cables, both left and right channels shown on the screen are exactly identical. If I unplug the left cable from the iConnex box, both channels displayed on the screen stop altogether. If I reconnect the white cable and disconnect the red, nothing changes - the two identical traces keep playing. This confirms to me that only the left channel is being recorded on both the left and right channels. The right channel is not being recorded at all (just like I thought I heard on my friend’s recordings).

To further investigate my test setup, I disconnected the iConnex box and, with the test music playing, I connected my dual-channel Tektronix 70MHz scope to the red and white ends of the audio cable. The left and right channel signals are indeed VERY different and easily discernible as two separate and independent channel sources. This result FURTHER confirms to me that the combination of the iConnex box and the Audacity software are not capturing a stereo recording but only the left channel of a stereo recording.

Furthermore, years after my friend acquired his iConnex box and gave it to me, I decided to buy a new iConnex box thinking that there was something wrong with his old one. I found one on line and bought it. When it arrived, I gave it a series of similar tests and the results are EXACTLY the same: The left channel is duplicated to left and right and the right channel is ignored altogether.

With the same amount of detail as I offer above, can someone explain what settings, preferences, connections and such need to be changed to allow me to record a stereo signal correctly?

Thank you in advance…

Check in the Windows Sound Control Panel that Windows is set to record 2 channel stereo from the device. Then Launch Audacity and ensure that Audacity is set to record 2 channel stereo in the device toolbar.

I split your post to a new topic because I think it is fairer to the other user to do that. It can get very confusing to answer two people in the same topic, especially if it actually is an equipment problem.

This FAQ shows you the settings change Steve suggests: . The FAQ applies to Windows 10 too.


Thank you for your reply! I wonder if it’s possible that I just can’t accomplish a stereo recording on this laptop. In it’s day, this laptop was the BEST that could be purchased (Quad core i7) and performs everything else very well to this day, video and photo editing, maps, etc. Is it possible that I need different hardware? If not, please comment on the screen capture(s) that I’ve attached (with any luck).
Audacity Recording Device.jpg

Please try the suggestion that has already been made to you. Connect the iCconnex so you can see it on the Recording tab of Windows Sound (the same tab that you have in the screen capture). If the Microphone 4-USB Audio CODEC is the iConnex, right-click over that.

In the window that opens, click the “Advanced” tab, then click the Default Format dropdown and choose “2 channel 16-bit 44100 Hz” or at least, some “2 channel” option. Then click OK and OK.