Real time are not applied after mixing and rendering two tracks

I have applied a real time effect via add a real time effect to track. There is problem, that after mix this track using mix and render I don’t hear this effect.
Please, could You help me?
Thank You.

Ensure that you are using the latest version of Audacity.
Look in “Help menu > About Audacity”. If it doesn’t say “Audacity 3.2.1” then you need to update:

I use latest version of Audacity. Audacity is automatically updated to me.

I have also tried to change language to English, for sure, but everything is just same.
So, after aplying mix and render, effect is removed and I don’t listen It.
Is It result of scrobbing, seeking, or playing head?

Did you check the version number? If the automatic update didn’t work properly, you could still have an older version.

I have Audacity 3.2.1.

Maybe problem is in effect. This effect is 32-bit VST. I have two versions of Audacity due to effects. I use both 32-bit and 64-bit effects, but 32-bit effects are not supported on 64-bit version of Audacity. Also, when I have tried to open My project on Audacity 64-bit version, program suddenly crashed. Also, will I have to select this effect by using mouse and then mix and render? Because I use on everything keyboard shortcuts, I am blind.
Please, if You have same issues, write here to this topic.

I’ve just tried Audacity 3.2.1 on Windows 10 to see if I could reproduce the problem. I installed the “basic set” of the recommended “MFreeFXBundle” VST3 effects, but unfortunately none of them worked properly. I’ll be logging a bug report shortly. For now, it seems to me that Audacity’s VST3 support is not yet ready.

Thank You for Your help. I have thought, that It is mistake on My system.
I have another question to be sure. How I know, that this VST is VST3?

If it’s available as a “real-time effect” (in the panel on the left of the tracks), and if you know that it is “some sort of VST”, then it is VST3.
VST / VST2 are not yet available as “real-time” effects in Audacity.

Done: "MFreeFXBundle" VST3 effects are unusable · Issue #3775 · audacity/audacity · GitHub

In Audacity-win-3.2.0-alpha-1-x64bit I noticed that when mixing down a track with a real-time effect,
that the plugin settings applied sometimes changed to the default. If the default settings on the plug-in were null, then the mix down does not have any effect applied.

A work-around is to save the real-time settings as a preset in the plugin, then apply that effect in the old-fashioned non real-time way from the effect menu.

Steve, I see that this bug report was closed as it appears to not be an Audacity problem. Do we need an update on this thread?

Trebor, do you still see this in 3.2.1?

Why It isn’t problem of Audacity? Is It a problem of plugins? I don’t think It so.

I know, that It isn’t good idea to reply inside of Trebor, but It is still here. I have both versions of Audacity on My system. I have tested both version and problem is same. Also, I have turned on automatic updates of Audacity.

The MFreeFXBundle VST3 effects didn’t work for me, but it seems that nobody else could reproduce the problem.
I did some further testing, and they didn’t work in Reaper either, which I think largely lets Audacity off the hook, especially as it seems that most people on Windows are able to use these plug-ins successfully.
I also searched on-line for similar issues with these plug-ins, but was unable to find any, so most likely the issue was with the Windows PC that I was using.

My guess is that it was a graphics driver problem on that Windows machine. Given that the PC was not generally used for audio work, and the graphics card works fine for everything that the PC is normally used for, and that I hardly ever use Windows, I’m not inclined to spend more time trying to get it to work.

OK. I understand It, but It is strange, that problem with real-time effects and mixing is just reason of computer’s graphic card. I have noticed, that another people haven’t such issues in Audacity community for the blind. But why? Question is simple.
They not use ‘add real-time effect’ function, or use Audacity of previous versions. They not mixed track with real-time effect using mix and render, as It is described in manual. Also, this is not problem just with Your plugins mentioned in this topic. Problem is with every plugins, which We have tested before. So It is usefull to apply effect to me using normal effect menu without ‘add real-time effect’ function.
Maybe another alternative will be to add a real-time effect track feature, which will be under audio track and to this track add real-time effect. After this mixing everything will be fine.

Yes, but it seems to be dependent on the plugin: only some apply different settings when rendered.

On 64-bit 3.2.1 the real-time effects list now includes 32-bit plugins,
which will cause Audacity to crash if any are selected …
64-bit Audcaity 3-2-1 showing 32-bit plugins.gif
This is a nightmare: I have plugins with the same name in 32 & 64 bit,
if I pick the wrong one Audacity crashes: it’s like a heads-tails version of Russian roulette. :open_mouth:

I have a similar problem too. So, when I have applied 32-bit plugin in 32-bit Audacity, everything is OK. I think now to the adding real-time effects using this option, which is this topic about.
But, when I have opened this project in 64-bit version of Audacity, Audacity crashes. I don’t know, if It is really of plugin version. One interresting thing is this with mixing and rendering. Now My question is: Why this feature will be there? Feature before to listen real-time preview with VST effect was great idea, as It is now. On those VST effects We have (eccept this bad add a real-time effect) function normal preview, as with normal effects.

I have a question to users of Audacity. Do You use real-time effect function in new version, or as It was before, so trough Effect menu?

Hello people.
I have asked another people about this problem. I have got a reply with same issue.