Re: Audacity 2.0.6 missing from "Open With" menu [SOLVED]

When I right click on a file, Audacity is not listed under “Open With”

When I “Search my computer” for programs, I can find Audacity, but the “Always Use This Program” box is greyed out…

Little help please?

And thank you very much, ahead of time.

It works for me on Windows 7.

Did you select Audacity.exe? Does now show-up on the “Open With” dialog, and does that work (before selecting “Always…”)?

What version of Windows are you running? Are you logged-on as an administrator? (I don’t know if that will make a difference.)

Windows 7… Yes I am admin… (Shoulda mentioned that earlier)

No matter how many times I select Audacity from the “search computer” results, it never “sticks”

If you ever added Audacity 1.3 Beta to “Open with” for some format, that old entry is stopping Windows adding Audacity 2.0.6. In that case you can download and run a .REG registry file to solve the problem:


Well, Gale

I followed the link… I downloaded, renamed, ran the file and it removed Audacity from the list I usually get when I “Search Computer”
I browsed to Audacity.exe and selected it, but the box to “Always Use” was still greyed out.

I rebooted, and it’s still greyed out.

I am fully accepting the possibility that I did something wrong, so don’t be shy to thump me over the head with it, if you see it ,-)


I renamed the EXE file, and browsed to it, and the “Always Use” box is still greyed out

If you never did add “Open with” for Audacity Beta then the problem is a Windows bug or bug in an app that set a previous association thus the Wiki solutions won’t address it.



The last solution on that page fixed it.

“checking if you have the File Association Helper installed. It’s included as a part of the WinZip package and overrides the default settings for how you deal with files, resulting in the greyed out “always use this program” box. Just uninstall it and it will go back to normal.”

Thank you for your help!!

Thanks for confirming what solved it for you.

I will mark the topic as [SOLVED] and lock it now.