Ran out of disk space while recording -attempting to recover

As the topic says, was recording for 2 hours, then when i clicked stop at the end of that time, i got an error messaging saying the temp file couldnt be saved or something to that effect. I realised my HD had filled up during this recording and was displaying 0 bytes. Audacity stopped working properly, i could see the waveform of the entire recording but couldnt play it it back, and all the menus were greyed out, so i couldnt save or export or anything. I hit ctrl+alt+del (im on windows 7), to force close audacity.

Before I did that, I located the temp files, about 2+gb worth, and copied them onto another drive for safety.

I started audacity again, but no message was shown about my temporary files and there was no offer to recovery an unsaved project.

So I’ve got these temp files - 11 folders labelled d00-d09 and d0a in this directory: audacity_tempproject31574e00. These are filled with .au files.

I’m trying to use the audacity recovery tool, but if i select any of these folders, it says there are no audio files inside: audacity_temp, project31574 or e00. If I select d00 i just an message saying “errors occured. see the logfile …audacity_recovery.exe.log” (which i cant find).

Any idea of what to do? Im sure some of this recording is salvagable if i have 2gb+ worth of .au temp files.

The bad news is that running out of disk space is bad - very bad. (don’t ask me how I know :blush: )
When completely out of disk space, Audacity can’t even save a recovery file. This is not a good place :frowning:

To access the log, look in the “Help menu > Show log”.

That folder should be pretty big. How big is it? (I know you said it was about 2GB, but check that you still have it).

I presume that you have made some free space on the computer and have the temp folder saved somewhere safe?
Try putting the temp files back where they were, (assuming that you now have plenty of free space) and restart Audacity.
Take care of that back-up.

Sorry i did mention that before: audacity doesnt present me with any messages when i restart with those temp files in place. Then when i close audacity, it says its cleaning the temp directory, and deletes the files! Yes i have the temp files backed up on a seperate drive.

i’m using audacity 2.0.4 by the way.

You have to select the “d” folders which actually contain the AU files. Each “d” folder can have a maximum of 256 AU files.

Did you time-sort the AU files then rename them into a consecutive sequence while time sorted? The 1.2 Recovery Utility does not see randomly named AU files like current Audacity uses.

The best plan is to make new folders, each containing the contents of four “d” folders. In each new folder, time sort and rename the AU files. About 1000 AU files (1 GB) is the most that the 1.2 Recovery Utility can comfortably handle.


thanks for the reply.

So I’ve got 11 d folders, with au files in. These are d00, d01, d02, d03, d04, d05, d06, d07, d08, d09 and d0a

So I should make copies of 4 of these folders, say d00, d01, d02 and d03.

And then i need to rename them? So I go into a folder, arrange the au files by the time they were last modified, and name them consecutively. And I can name them anything as long as they are consecutive, like 0001, 0002 and so on?

If I’ve understood right, is there a program i can use to do this or do i have to manually rename 1000 files?

It’s what it’s programmed to do, because there is no autosave file from which to recover the project.

Have you looked in UsersAppDataRoamingAudacityAutoSave? If you ran out of space fairly late on there may be a temp file in there that could be useful if you renamed it to have autosave extension instead of .tmp or .temp. See here if you need to show hidden files and folders: How to see hidden files in Windows .


Actually yes there is. Theres a 144kb which was last modified at the minute that i stopped the recording.

New Project - 2014-01-30 17-59-03 N-2.tmp

what do you suggest i try and do with this?

This is what you would do if using the .tmp file in the AutoSave folder doesn’t work out.

Good - that’s the correct sequence of folder names.

I would create the first new folder, it doesn’t matter what it is called.

Open d00, CTRL + A to select all, right-click > Copy, then in the new folder, right-click > Paste. Repeat for folders d01, d02 and d03, so you have 1024 randomly named AU files in there.

I would use xplorer2. See Missing features - Audacity Support .

If you don’t mind installing python 2.7.6 , there is a script you can try which would attempt to create a new AUP file from the data, so you don’t need to do the sorting, renaming and piecing together of recovered WAV files: https://forum.audacityteam.org/t/alternative-recovery-tool/30964/6 .


Make a backup copy of it first, then rename the original to New Project - 2014-01-30 17-59-03 N-2.autosave.

Open the renamed autosave file in Notepad or similar. Make sure that datadir=" points to the folder where you have the backup of the temp data. Inside that folder, you want an “e00” folder and then the original “d00” through to “d0a” folders. The folders must be called that and the AU file names must be the original random names.

Note that whatever the recovery method, data corruption will have started as soon as you ran out of disk space. It won’t be perfect.


Okay I’ve tried renaming the .tmp file to .autosave and making sure the temp files are in the correct directory.

I open audacity, it gives me the option to recover the project but then i get an error message:

Error: not well formed (invalid token) at line 2826.

I guess i’ll give up on this method and try the renaming method above, unless theres anything i can do here?

ill try and get my head around this python thing and see how it goes.

You can open the renamed autosave file in Notepad, turn wordwrap off and look at the line 2826. The problem will probably be an empty line which should be removed.

Attach the autosave file if you are not sure. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1 .


Okay i installed python and used that script, looks like its all worked out fine. got most of the recording back, seems to cut short about 80% of the way though but i can deal with that, going to see if theres any corruption by listening, but it looks good.

Only problem i had is that script was looking for files in project####_data and my directory was just project#### . so i just added _data after the project#### bit and it found the files. thanks for all the help.

Well done. :slight_smile:

Sorry for the trouble caused.