Queen Mary Vamp plugin fails

Hello All,

I am trying to enable the Queen Mary Vamp plugin but I get an error that says it can’t load the library. I’m using Windows 10 and am on Audacity version 3.0.2. I was on a later version of 2.x and had the same problem. I was hoping an upgrade to 3.0.2 would fix the problem but it did not.

I read there was at one time a problem with the Queen Mary Vamp plugin on Windows 10 OS…but I thought it had been fixed with an upgraded version prior to (1.8.0).

The plugin shows up in the “Manage Plug ins” dialogue box but when I try to enable it I either get the error mentioned above or it just sits there and does nothing.

Does anyone have any suggestions?

See if this post helps: https://forum.audacityteam.org/t/vamp-plugins/50597/3

Thanks Steve. I appreciate you responding and trying to help.

I had already seen that thread and tried it to no avail… I can see the plugin available in the manage plugins dialogue box but it doesn’t work… At first it showed up as being “New” and when it wouldn’t “Enable” I tried changing it to “Disabled” which it did take…but then it would not allow me to switch back out of the “Disabled” state…I even went into the pluginregistry.cfg file and manipulated the plugin to show that it’s enabled but the plugin still doesn’t load the effects… Apparently, from a popup I got, it can’t register, whatever that means, so it fails to load…Now I don’t even get the popup any longer…

See attachment for the fail notice…https://forum.audacityteam.org/download/file.php?mode=view&id=31621
QM fail.png

but you’re still installing the Vamp plug-ins in the wrong place.
That post points to this page in the manual: https://manual.audacityteam.org/man/analyze_menu.html#vamp
which says that for 64-bit Windows, Vamp plug-ins need to be copied to:

C:\Program Files (x86)\Vamp Plugins

Also, double check that you have the correct version of the Vamp plug-ins.
I’ve just tested with “qm-vamp-plugins-1.7-win32.zip” and it works fine with Audacity 3.0.2 (you have to extract the contents of the ZIP file and put them into: C:\Program Files (x86)\Vamp Plugins\

Hi all,

Ok…back to try again. I placed the Vamp ‘contents’ into the Program Files/Vamp Plugins.

Reading the manual at: https://manual.audacityteam.org/man/analyze_menu.html#vamp

It would appear that I need to modify the “VAMP_PATH environment variable” Plugins path for the Vamp plugins to point to the Program Files/Vamp Plugins folder.

How do you do that? I see where I can either enable or disable the paths in the “Tools>Add/Remove plugins” tab but I see no place to change the locations for the plugin.

Or am I reading more into this than there is to it?

Windows 10…Audacity Version 3.0.3


I found it…I FOUND IT!!!

I uninstalled version 3.0.3. I then uninstalled the old Vamp plugin (Version 1.7). I then went in and deleted all the old Audacity files in Program Files (x86) (I think I just installed the 64bit version (3.0.3) without uninstalling the old 32bit version). I went in to AppData and found all references to Audacity and deleted those as well. In other words I removed everything Audacity related and then re-installed Version 3.0.3. I then ran the Vamp QM installation in lieu of just dropping the files from the .zip file into the Program Files Vamp Plugins folder.

I then went to the “Analyze” tab and used the “Add/Remove Plug-ins” option.

The Vamp options are now available in the “Analyze” tab… I guess something was resident from a previous install that was throwing the path back into the Program Files(x86) folder to look for the Vamp plug-ins…or at least that’s my theory and I’m sticking to it! Haha… :laughing: :smiley: