Quality of the recorded sound

Hi everybody,
My request is about quality of the sound recorded with Audacity on my Linux Mint 15 Olivia KDE. Actually, I use both Linux and Win 8 systems, but I am prone to use Linux more just because I like open source systems and programs. Yet, there is a huge gap between the outcome I get when recording on Win 8 and Linux Mint. I would say that the quality of the sound with Audacity on Win 8 without any changes in options (just installed 2.0.3 as it is) is better than that on Linux Mint after reducing all the noise and enhancing the quality. The only differences between those two programs is MME on Win 8 and ALSA on Mint (not an extraordinary thing, I reckon), and on Win 8 I use Realtek drivers while on Linux the option is DEFAULT (others are pulse, or HDA Intel). On Win 8 the sound is clear withour any action while on Linux I have to remove noise and enhance it, and still it is worse than that on Win 8 which can be heard especially during pauses inhearable on Win 8 but some strange electronic-like sounds on Linux can be heard. Doesn anyone know how to improve the sound on Linux?

You should post the linux sample without any “corrections.”

Here it goes.

The electronic “tinkly” sounds were almost without question your misapplication of Noise Removal which is why I wanted a sample before you did that.

The sign above the automotive garage: $30/hour to work on your car. $60 if you worked on it first.

Your distorted track is monstrously overloaded and there may not be anything else wrong with it. It’s as if you were using a sound mixing desk and pitched forward in a dead faint accidentally pushing all the volume sliders all the way up as you went.

Set up Audacity for recording (but don’t record yet). Right-click on the red recording meters > Start Monitoring. That will turn the meters on. Play the work. I bet the meters smash themselves violently against the right-hand edge. Your job is to reduce the volume of the work until they stop doing that.

This is what a nice recording display looks like. Actually, you already know. Your other track is perfectly recorded.



Try turning the volume down in the Mixer Toolbar.


My joke is That I could clear a room in 30 seconds at work by walking in and announcing: “Hi. I have a Linux audio problem. Can anyone… Um.” [papers fluttering to the floor in an empty room].


Sorry. One more. You’re complaining about the faerie sound of the Windows recording? Did you turn off Windows Enhanced Services?



There is much more surface noise in the Linux recording even allowing for the fact that it has been boosted above 0 dB.

The Default choice gives you pulse on systems that use pulse. Do you have pulse audio volume control installed? If not, open a terminal, type

sudo apt-get install pavucontrol

and follow the instructions.

Are these different computers or the same computer dual booting Windows 8 and Linux Mint?

Please say more about what you are trying to record, what equipment you are using to do that (make and model numbers) and how that equipment is connected to the computer. Are you using exactly the same recording equipment for both Windows and Linux?


Thanks a lot for your replies, I did not expect so quick and detailed answers. I will follow them all and I am sure that will help. I knew that there was something wrong with recording voice loud, but when I tried to record it at low pitch, it was almost unhearable and I was afraid that someone listening to it will not be able to increase the volume in his device to hear it properly.

Koz: You are absolutely right about the notice at the garage. They are very often seen here in Poland and I always laugh at them…because there is some truth in the “reality” they describe :slight_smile: The problem I have is thinking (still, because it is hard to get rid of “windows thinking”) that if I have two systems and the same program, it should work the same with no changes in its options. Yet, Linux, as usual, requires some adjustment, which is obviously its advantage, not a downside.
Oh, by the way, why are people trying to discourage others from using Linux or are afraid to use it? I can afford original Windows, I have been using it from 95 version. But I see a really cool thing to use something that other people created in their free time and for free, something that is fully adjustable to the user, the only “problem” is that we all have to learn to see the system from a different perspective. So, the joke “in the office” is really funny as I know some IT professionals who tried Linux and now they avoid it at any cost :slight_smile: I must proudly say that I managed to install on Linux almost all programs I use on Windows. Being really inexperienced in this system…

Gale: I am a teacher of English who records exercises for his students. I believe I can improve their learning when they hear, not just see, the sentences. I know it takes a lot of time and effort, and sometimes looks like a spoon-fed solution, yet it is worth it in my view since it can speed up their language acquisition. So, when I spend most of my time using Linux, I would not be especially keen on switching to Windows to make a recording, all the more, I have the same program in the Linux system. I have two systems on my Samsung laptop and I use Grub to switch between them. I use the same pair of speakers with a microphone (A4Tech HS-7P) connected to the sockets in the laptop. I do not need any pro equippment, I am realy happy with the quality I get with Audacity on Windows. I believe it is possible to obtain it on Linux and not only just to prove I can manage. I have also pavucontrol installed. I understand that I need to switch to pulse and then reduce the volume in the mixer.

Thank you very much for your hints again. Now it is my time to put them into practice :slight_smile:

One more thing, the option to reduce the volume of recording is inactive in the program. I need to go to the system mixer to change it and only there. Maybe that is the problem.

Ok, what I did is: I opened the control panel of pavucontrol and reduced the input level to some 30%. Below two samples, one original and the other after removing noise. It`s quite quiet I think, but now it is really close to the Windows recording without any additional action (yeah, I know, I should be happy with it :slight_smile: sooorry I am not :smiley: )

That is probably not the cause of the problem, but the greying of the Audacity input slider is normal when you select pulse or its aliases in Device Toolbar - PulseAudio doesn’t support ALSA’s mixer interface and Audacity can’t directly control the input device’s volume slider except through that ALSA interface.

You could try selecting the (hw) input for the mic in Device Toolbar, which should bypass pulse and enable the Audacity input slider. I would not expect it to help though. The problem remains that you have a much greater level of background surface noise on Linux than Windows.

Is this what you have (a headset http://www.a4tech.com/product.asp?m=&cid=66&scid=221&id=269)? If so does adjusting the input control on the headset help?

I would guess the issue could be that Windows exposes a boost control for the mic which you have turned off, and ALSA or pavucontrol doesn’t expose that (or you can’t see it in pavucontrol).

Have you opened a terminal and typed


I have a boost control in alsamixer for the external mic that has three settings which seem partially independent of the pavucontrol slider - it is certainly confusing.


I think the outcome is satisfactory and further enhancing to reach the level of quality with Audacity on Windows is pointless or hair splitting, I should say. As I said I should have been happy with the Windows performance, but hopefuly I was not, now there is another program which has its functionality on Linux comparable to Windows and I can use it. One step forward.
This is exactly the same set I use. Not very expensive one, but the quality of sound it quite alright. There is a slider to control the volume as well. I must say you are great Gale. Why? My laptop has been designed to be used with Windows 8. Using Linux on it is my caprice (it is not even recommended to install it next to Windows). And…it seems the cooler works a bit louder stopping rarely (on Windows it is dead silent) and this is something you could not have known :slight_smile:

By the way, in ALSA my MIC was set at 0 level. Maybe I should increase it a bit.

Thank you very much indeed for all your hints, they helped me to understand Audacity more as well as the outcome now is a lot better even if quiet. Will work on it more.