Pyle pmxu43bt mixer is recognized, but does not record

I recently picked up the Pyle pmxu43bt mixer. However, once I connected it to my Windows 10 loaded laptop via USB, fired up the latest version of audacity, 2.4.1, and tried to record something… anything, nothing would record. I made sure to select the recording device as JieLi BR17 (the device software installed for the mixer board) and I tried all three Audio Host options. The kicker is that when I click on the Recording Meter Toolbar and activate the “Click to Start Monitoring” I get proper sound being detected from the mixer board. It just doesn’t record anything on the track, even when I click the record button. All I get is a flat line.

I’m certain I’m missing something, but I just don’t know what. Any ideas?

Okay, I was stupid. I didn’t think I’d have to set two of the volume knobs up near the max level. But that’s what it took. Now to figure out how to kill the buzzing.

The Pyle has volume meters. Can you make the 3 green lights come on comfortably? Is it buzzing in your headphones connected to the Pyle?

Don’t start diagnostics with Audacity. That’s the last thing down the chain.

Screen Shot 2020-06-06 at 19.20.08.png

I am having the same issue. It says it’s there but I am not hearing anything nor can I tell if any sound is coming through.