Punch Copy/Paste problem

Yesterday I installed the plug-ins for Punch Copy/Paste and Punch Paste. I then created a keyboard shortcut for Punch Paste.

Next I used Punch Copy/Paste to copy a short section of silence/room noise with these settings:
Copy(replace); Enable looping; Linear; Max crossfade time 0.000; Paste mix 100%

I then got a confirmation message like this: Punch Copy/Paste 0.906 sec copied

I then highlighed a short section where I wished to remove breathing noise and applied my keyboard shortcut for Punch Paste which gave the error message:

Clipboard empty
Use ‘Punch Copy/Paste’ first.

Naturally I have repeated the process many times, with the same result.

Please can anyone help!

Windows 10
Audacity 3.1.3

In “Punch Copy/Paste”, click on “Manage > About”.
Does it say:
“Version: 3.0.2-1”

No, it doesn’t. It says, “Version: n/a”
Your question makes me think I might not have the latest versions of the 2 plug-ins.

Try this version:
PunchCopyPaste.ny (10.1 KB)

Steve, thank you!
After further failed attempts I resorted to reinstalling Audacity; then your link to Punch Copy/Paste worked first time.
I am most grateful to you. Now I can get on with the project!