Punch and roll recording error message


I’ve been happily using Audacity for audiobook production for over a year but I want to start doing punch and roll recording. Unfortunately, I keep getting this error message when I try it:

“Error opening recording device
Error code: -9997 Invalid sample rate.”

The project rate is set at 48000Hz. I’ve checked in the sound control panel and my interface is also at 48000Hz. I’ve tried changing both to 41000 but the error still occurs. I’ve tried switching between mono and stereo but that didn’t help either.

However, this only happens when I’m trying to record through my external mic and interface (NT1 and U22 XT) - if I use my computer’s built-in mic then the P&R works perfectly.

Does anyone have any idea what’s happening and how I can fix it?

I’m using version 3.1.0.

Thank you.


Is there any chance of someone taking a look at this? I have the same problem. I have used Audacity for years with now problem but now in Windows 10 with a Behringer U-Phoria UMC202HD interface I am getting “Error opening recording device. Error code: -9997 Invalid sample rate.” I can record onto the end of an existing track by pressing the Record button but get this error every time I attempt to use Punch and Roll. If I use a USB mic I can do punch and roll. This problem is crippling my workflow and a solution would be a fine thing!

… sample rate is set to 48000 in Windows Sound Control Panel and in Audacity.

(I don’t personally use Punch and Roll but the issue is mostly the same as for Overdubbing.)

So as you have each noted, this issue can be caused by a mismatch in sample rates as well as a mismatch in the number of channels (stereo or mon).

As you have mentioned, when you run mmsys.cpl from the magnifying glass on the Windows Taskbar, check the the Default Format on the Advanced Tab of Properties for both your recording and for your playback devices. They should be the same as the Audacity Project Rate at the lower left-hand corner of your Audacity window. If 44100 fails, try 48000 on all of them.

The number of recording channels (normally set at the highest number available), should also match.

Another thing worth trying is to try changing the Host from MME to WASAPI or DirectSound.

If these fail, a re-boot can sometimes do the trick.