Punch and Roll record won't actually record

I’m using Windows 11 and Audacity 3.1.3. I have my mic plugged into my M-Audio M-Track Duo interface, which connects to my laptop via USB.

I have been using this exact setup for over a year and it works perfectly, no problems.

Suddenly, about a week ago, when I hit Shift+D to Punch and Roll, it deletes the recording from the insertion point forward, as its supposed to, but it doesn’t start recording. Also, when I want to do some punch in’s, I select the section in my track that I want the new track to record over – it creates a new track, but stops… doesn’t start recording.

I discovered today that if I disconnect my audio interface from the laptop and select “Microphone Array (Realtek)” from the input drop down in Audacity, it works fine. But then when I plug my interface back in and select IT as the input device, problem resumes.

So it doesn’t seem to be Audacity, per se, but how Audacity is perceiving my input devices.

I haven’t made any changes at all, no driver changes, no new wiring, no new programs, nothing. Other than Windows Updates, of course, which run all the time. I was running the previous version of Audacity, so I updated it to 3.1.3, no change. I checked to make sure the driver for my M-Audio device was up to date and it is.

With this problem, I CAN still record, straight. I want to make sure that’s understood. I just can’t punch and roll or punch in because something is stopping it from recording within those functions.

HELP! Any suggestions?

UPDATE: Plugged everything back in at home. Worked ONCE, then 5 minutes later, didn’t work.

I just don’t understand.

Could my 1 year old interface be stroking out? Maybe a new XLR cable to connect the mic? I really am just out of ideas and VERY frustrated!

If I new what the differences were – technically, behind the scenes, programming wise – in RECORD and PUNCH AND ROLL RECORD, that might help me figure out why the latter won’t work but the former will!

[Just trying to straighten out the time line here…]

Did you happen to see any gremlins when you looked under the machine?

LOL I wish I found Gremlins. At least I’d know what it was!

If you seriously want a timeline, I’ll give it a shot.

  1. For the past year, everything worked GREAT.
  2. About 2 weeks ago, suddenly (after no changes on my part), Punch and Roll and Punch In recording won’t record. Straight record button DOES work however.
  3. I googled until my fingers bled and found NOTHING. I can’t believe no one has even experienced this before!
  4. I unplugged and replugged EVERYTHING (because I work in IT, and I mean, that’s always something to eliminate).
  5. I upgraded from Audacity 3.1.2 to 3.1.3, just in case. NO CHANGE.
  6. I checked the driver for my audio interface (M-Audio M-Track Duo), and Windows says I have the best one. M-Audio’s website says to get my driver from Windows, so…
  7. At a loss, I took everything apart and brought my laptop, audio interface, XLR cable, and mic to a friend who knows stuff, so he could help me figure out it. I plugged everything in, and guess what… IT WORKED. There was NOTHING different than at home, no different cables, no other equipment… exactly the same. So I said, okay, what a glitch, I’ll bring it home. What a shame it’s fixed, but I won’t know what caused it.
  8. Plugged everything back in at home, and here’s where it gets REALLY freaky, IT WORKED:
    A. After it was working, I plugged in my headphones into the audio interface (I hadn’t before because I wasn’t listening to anything), and it DIDNT WORK. So i said, okay, weird, it’s the Headphones! (yeah, i know).
    B. So of course, i UNPLUGGED the headphones to test that theory. Nope, still didn’t work. So that wasn’t it.
    9.So I decided to unplug and replug EVERYTHING, thiinking maybe it was something loose.
  9. It worked. Then it didn’t work. Then it worked. Then it didn’t work.
  10. I jiggled the XLR mic cable, and it worked. But then it didn’t work no matter how much I jiggled it.

So I can’t scientifically figure it out. I’m going to borrow an XLR/XLR cable from something and swap that out first, to see if it’s a connection problem with my mic cable.

If not that, maybe replace the USB cable that connects my interface to my laptop.

If not that, all that’s left is to buy a replacement interface. I can’t afford that, and I can’t afford another XLR mic.

So, any suggestions??? Honestly, I think if someone from Audacity can tell me TECHNICALLY what the differnce is between STRAIGHT UP RECORD BUTTON and PUNCH AND ROLL and PUNCH IN recording, because they work slightly different than straight up record.


No, the OP is not crazy. I have what seems to be the same problem with v. 3.1.3. More precisely, there is no pre-roll. No matter what I set the pre-roll duration to, when I hit Shift-D everything starts from that point immediately.

Actually, the other audio tracks start from that point forward, while the track I am trying to punch and roll in does indeed go back the prescribed number of seconds. So, again, the OP is correct, the tracks are not synchronized when performing PNR.

Does this look like the same issue? https://github.com/audacity/audacity/issues/2162

Yes, that I believe that describes exactly the same issue.

PS - If you set Preroll to 0 all works as expected … but you have to be able to jump right in.