Pulsing sound on recording

I’m using Audacity 2.2.2 a Tascasm iUR2 midi/usb interface to record band/guitar/vocals/etc via mic/direct guitar/and/or aux line out from a mixer. There is a low level pulse being recorded (repeats every ~1.1seconds). I’ve read previous forum entries and the Transport option ‘Software Playthrough’ is turned off. Also Overdub on/off doesn’t seem to matter.

All thoughts appreciated. It feels like some clock setting is misaligned or should be turned off.

Attached is a screen shot of a recording with a few seconds of “testing testing” input thru a mic

Thanks for any help
Capture pulse.JPG

I found the manual for iUR2 online and it says there’s an iOS/Computer switch on the bottom. Make sure it’s set to “Computer”.

Otherwise, most “digital glitches” are related to multitasking.* Usually noise is an analog problem but the uniformity of those spikes makes me think it’s a digital issue. Don’t run any other applications while recording, and try to minimize the background operations. (Windows is always multitasking even if you’re only running one application.) Some people get better results when they disable the Wi-Fi and/or anti-virus. (Your user manual actually suggests that in the Troubleshooting section.)

Also try increasing the [u]Latency/Buffer length[/u].


  • Usually what happens is this - Some other application/process/driver hogs the system for a few milliseconds too long, the recording buffer overflows, and you get a glitch.

Thanks DVDdoug. Usually Audacity is the only program running unless the web browser is open. I’ve been able to use a Focusrite Scarlett 2i2 audio interface instead of the Tascam iUR2 and the pulsing noise did not appear, but there was a latency issue. So I had to play with the buffer/latency setting in Audacity, which I had never done.

I will fiddle with b/l setting with the Tascam.

Thanks again for your time and suggestions.

but there was a latency issue.

From what I found on the Internet, both of these interfaces should have a zero-latency direct monitoring option. Check your owner’s manual for how to set that up.

With direct hardware monitoring you can use a big buffer with high latency and it won’t matter, since you’re not listening through the computer.

There is always latency through the computer although it can sometimes be brought-down to an acceptable/unnoticeable amount. With direct hardware monitoring your monitoring path doesn’t go through the computer so there’s no latency! (You can still monitor a backing-track from the computer while recording.)

Latency and buffering -
…When you record the digital audio stream flows-into a buffer (memory) at a smooth-even rate. Whenever the operating system gets around to it, it reads the buffer in a quick burst and writes the data to the hard drive. If it doesn’t read the buffer in time the buffer overflows and you get a glitch (missing data). Of course a larger buffer helps but a larger buffer means more delay. A faster computer can help as can running fewer background tasks because it can finish the other tasks and get back to audio sooner.

There is an output (playback/monitoring) buffer too. The output buffer works the opposite way. It gets filled in a quick-burst and flows-out at a smooth-even rate. If the buffer doesn’t get re-filled in time, you get buffer underflow and a glitch (a gap in playback).

When you are monitoring yourself through the computer the audio gets delayed by both buffers.

…unless the web browser is open.

If you are recording streaming audio, latency doesn’t matter. And, if you are not recording streaming audio you shouldn’t have the browser open.