"pulse" is not available as a recording device [SOLVED]

I am following a guide to record my pc’s playback using Audacity, Pulseaudio, and ALSA. Here is the guide: http://manual.audacityteam.org/o/man/tutorial_recording_computer_playback_on_linux.html

But on step 2 of that guide where it says “set the Host to ALSA and the recording device to pulse”, I cannot find “pulse” under the recording device. My only option for recording device is “HDA Intel PCH: ALC3232Analog (hw: 1,0)”. As a result, I cannot find any reference to Audacity ALSA plug-in under my pavucontrol’s “Recording” tab. Otherwise pavucontrol, ALSA, Audacity, and the rest of my sound setup seem to be working fine.

Am I missing a specific package, or plugin? I am running ArchLinux, a minimal Linux distribution, so I suspect there is a package that I am missing. Any help would be appreciated!

Here is a quick list of available ALSA packages on Arch, as well as a description of whether they are installed on my system:

[eartheaterrr]/home/eartheaterrr$ pacman -Ss alsa
extra/alsa-firmware 1.0.29-1
ALSA firmware package
extra/alsa-lib 1.1.0-1 [installed]
An alternative implementation of Linux sound support
extra/alsa-oss 1.0.28-1
OSS compatibility library
extra/alsa-plugins 1.1.0-1
Extra alsa plugins
extra/alsa-tools 1.1.0-2
Advanced tools for certain sound cards
extra/alsa-utils 1.1.0-1 [installed]
An alternative implementation of Linux sound support
extra/alsaplayer 0.99.81-7
A heavily multi-threaded PCM player that tries to excercise the ALSA library and driver quite a bit
extra/gnome-alsamixer 0.9.7-1
Gnome ALSA mixer
extra/pulseaudio-alsa 2-3
ALSA Configuration for PulseAudio
extra/zita-alsa-pcmi 0.2.0-3 [installed]
The successor of clalsadrv, provides easy access to ALSA PCM devices.
community/a2jmidid 8-1
A daemon for exposing legacy ALSA sequencer applications in JACK MIDI system.
community/balsa 2.5.2-1
An e-mail client for GNOME
community/clalsadrv 2.0.0-2
C++ wrapper around the ALSA API
community/lash 0.6.0~rc2-9
A session management system for JACK and ALSA
community/patchage 1.0.0-3
A modular patch bay for audio and MIDI systems based on Jack and Alsa
community/python-salsa20 0.3.0-3
Bindings for the NaCL implementation of Salsa20 and XSalsa20 by D. J. Bernstein
community/python2-salsa20 0.3.0-3
Bindings for the NaCL implementation of Salsa20 and XSalsa20 by D. J. Bernstein
community/qmidiarp 0.6.3-1 (lv2-plugins)
A MIDI arpeggiator, phrase generator and controller LFO for the ALSA sequencer.

Have you tried installing the pulseaudio package? See https://wiki.archlinux.org/index.php/PulseAudio#Installation.

There are other methods of recording computer playback mentioned on http://manual.audacityteam.org/o/man/tutorial_recording_computer_playback_on_linux.html that don’t require pulseaudio.


Yep, I had pulseaudio installed. I was able to fix this issue by installing the alsa-plugins package. Apparently, alsa-plugins is installed by default on most distros, but not Arch.

After installing alsa-plugins, there is a pulse device that I can now select, which is detected by pavucontrol as well.