proper microphone driver

When I select MS sound mapper or 4-USB audio as microphone I get no sound. When I select Realtek I get sound but poor quality. In the past
I had 6-usb audio codec and that worked well. How do I get back to 6-usb? And what do these digits mean anyway?

When Audacity starts up, it asks the system what audio devices are available. The sound system then fetches the names of the devices from the sound card drivers. Some sound cards have multiple devices, for example, a surround sound capable sound chip may report “front”, “rear”, “side”, “lf” as separate devices. Other sound cards may number their devices, such as “HDMI 1”, “HDMI 2”, “HDMI 2” …

If a device is listed, that does NOT necessarily mean that it is physically available. For example, the built-in sound card in my laptop reports 7 analog channels for sound output, because the audio chip has 7 output channels, but only front left and front right are actually wired up to anything.

So, in short, the names of the devices are whatever the sound card driver says they are called.

I guess the manufacturers thought this audio thing isn’t confusing enough…

My Shure X2U microphone interface arrives as “Shure Digital,” but the Behringer UM2 interface arrives as generic “USB Audio CODEC”.

There is a trick to this. Look at the devices available in the Audacity Recording (Microphone) toolbar. Close it. Connect or disconnect your device, Transport > Rescan. Look at the toolbar again and see which device vanished or appeared.


When I select Realtek I get sound but poor quality.

Nine times out of ten, “poor sound quality” is an analog/acoustic problem.

Are you using the mic built-into your laptop? If you are using an external mic, please tell us which one.

What are you trying to record? Your voice? A rock band?

Can you describe what’s wrong with the sound? Maybe [u]post a short sample[/u].

…It’s not easy to get a professional-quality recording. I generally takes a good stage/studio microphone and a good audio interface (or a good quality “podcast” USB microphone) and it really helps if you have a soundproof & sound-absorbing “studio”.

I am following the advice

Disconnect Behringer mixer
Re-scan Audio devices
7-usb has vanished
re-connect Behringer mixer
Re-scan Audio devices
7-usb is back

This doesn’t take me much further, does it? I still get a flat-line on recording. In the past with the same set-up I got sound. How do I proceed now?

I have a sample with realtek. How do I post it.
In the past I have had acceptable recordings. I’ll post one when I know how to do that

See here:
Short samples (around 5 seconds if stereo or 10 seconds mono) are best posted as WAV files.

Hello all,
The problem is not so hard as others have made it sound. The question is really all or nothing.
In the past I was able to use Audacity to obtain ‘acceptable’ recordings. I’ll post one when I understand how to. See below
Now I cannot get a recording at all; as I explained I get a flat line with 7-usb and a poor recording with realtek. My question therefore is ‘what is different between my configuration in the past and my configuration now which will account for the difference as above?’
Many thanks,

Floral dance is what I regard as ‘acceptable’
hc with realtek is definitely not

The “realtek” sounds like it has an “enhancement” such as echo-reduction or noise reduction.
The “enhancements” are applied by Windows, not Audacity,
you need to disable them if you are recording a musical performance, see …


There may be “enhancements” in the Recording tab, as well as the Playback tab …

If that doesn’t solve the problem, look in the realtek audio manager for similar enhancements (a/k/a “effects”) & switch them off …