Projects cannot be opened in 3.1.3

I have just tried to open a project from last year in 3.1.3. It was created in 2.3.3
When it opens it fails on the import.
If I uninstalled 3.1.3 and reinstall 2.3.3 the project opens fine so it looks like a problem with 3.1.3
As a result, I’ve been through all my projects and converted them to .AUP3 just to be on the safe side.
I’m now left with two that will not import.

I’ve attached both of the .aup files to see if anyone can spot what is causing the problem. Both of them open fine in N++ and the _data folder is present/unmangled (hence opening fine in 2.3.3)

I even did a save as on the projects to see if that would generate a new file that worked. After upgrading to 3.1.3 they still failed to import.
hab.aup (60.9 KB)
Losing My Religion.aup (24.1 KB)

Do you get an error message? Do you want to share a screenshot?

What happens when you try to import the project?

Thanks for the reply,

I don’t get anything specific, it just says “Couldn’t import the project: Could not load file: XXXXX”

Doesn’t matter whether I open or import it produces the same.
That’s why I’m assuming there’s something particular in these two projects that is tripping a failure on the import routine and I’m hoping someone who understands the process can see it - the .aup files look fine to me when I compare them with the projects that I was able to import.

What is the “D:” drive?

It is the drive that the files are on but I have copied elsewhere to try (I’m a trained technical IT director in the MSP so hopefully have the basics covered!)

I notice that both of these projects have a selection starting in negative time. I don’t know if that is the cause of the problem, but it’s unusual and both projects have that.

Here’s the files which I’ve modified so that they are not selecting negative time:
Losing My Religion.aup (24.1 KB)
hab.aup (60.9 KB)

Awesome, thanks Steve.

That does in fact appear to be the problem. I’m guessing I had a track selected and then moved it to the left or something and the last save still had it selected before the start that way.

Both tracks are now saved as aup and I know what to do to fix it if it ever crops up again.
Is it something worth putting in a bug report somewhere as I imagine someone will probably hit it at some point and be similarly stuck?

If I can reproduce the problem (I’ve not yet tried), then I’ll log it as a bug.

Yes, it’s easy to reproduce, and I think easy to fix.
I’ll log it now, along with a proposed fix.