Program Freeze when selecting Export

Hello. I have been using Audacity to record commentary for YouTube videos for the past couple years with no issues. During the last few days a problem has popped up that makes it completely unusable for me, so I made this account to ask for help.

I recorded the track without issue, roughly thirty minutes. The problem arises when I try to do anything other than simply record, play, or delete an audio track. The thing I was trying to do was export: I would click File, Export Audio, and then within a second or two as I try to name the file the program freezes completely. I am still able to do whatever else I like on the computer, but Audacity hangs there indefinitely and can only be closed by the Task Manager. I tried several times, and found that trying to save had the same issue, as did something as simple as clicking anywhere within the audio track itself. I was using the latest version of the program (3.4.2) and have tried completely uninstalling and reinstalling only to have the same issue.

Windows 10 laptop, and, as noted above, have had no issues for years up until the last few days. Any help that you can provide would be greatly appreciated. Thank you for your time.

And if no one can help with this issue, can anyone recommend a good alternative program to use? I like Audacity and would like to continue to use it, but so long as this freezing persists it is absolutely useless to me and I need to record my audio somehow. All three people who watch my YouTube videos need me!

Since I did not see any other complaints about the issue you describe: what did you change in your computer (installed or updated other software, changed something in system software, antivirus software, etc.)? I am using Audacity on Linux Mint and on macOS without any problems.

The only thing I did lately in that vein is uninstall a few games from Steam. Not counting, of course, uninstalling and reinstalling Audacity itself.

You may find a log file from audacity which could give more light about the issue - for this, you go tothe menu “Help” and then “Diagnostics → Show log”. Also, “Diagnostics → Generate support data” could be helpful.
See Help Menu: Diagnostics - Audacity Manual
You can probably also send this data to Audacity support team – however, I could not find an address for them at the moment.

Thank you! The diagnostics log had the clue I needed: it said it could not find a specified module, so I searched for the error message and found a download for FFMPEG library, installed that, and now Audacity works again. No idea why it suddenly started needing this thing after working fine for years, but so long as it is working I will not complain. Thank you again!