Problems with audacity on ubuntu 22.04

I am using audacity on linux ubuntu 22.04, and I have 2 questions :

1/ Configuration : In Edit->Preferences->MIDI devices : I cannot select anything, for “host”. I don’t see ALSA (I read “No MIDI interface”).

On my Windows 10 installation, I see : “MMSystem” ( even if no MIDI device is connected to the computer). I think that on ubuntu, I should see ALSA instead, but it does not appear in the choices (I only see “No MIDI interface”).

2/ I can’t use the mic slider (it is set to the maximum : 1. and I can’t set a lower value using the mouse on the slider. I need to use the ubuntu pavucontrol to change the mic volume). Is it normal, on linux ?

I tried on audacity 2.4.2, and on audacity 3.1.3 : same problems with these 2 versions.

Thanks in advance for your responses.

Try installing “Timidity-daemon”, then reboot the computer.

That’s normal on Linux. Use the system’s “Audio Mixer” instead. The Audio Mixer provides much more control than Audacity’s slider would be capable of - including allowing you to select any available audio source.

Thanks for your response !

So, ok , I’ll use the audio mixer.

I have tried to install timidity-daemon, but I got an error after installing it, and a core was created under /var/log.
~$ ll /var/crash/
-rw-r----- 1 timidity whoopsie 1214646 mai 21 23:27 _usr_bin_timidity.125.crash

I have a question, before trying to solve this problem :
Is MIDI configuration mandatory, to use a usb microphone.
I am using audacity to record my voice, with a USB microphone. I have set ALSA in Edition->Preferences->Devices. And do I really need to set ALSA in MIDI devices , too ?
I have tried to record my voice on audacity with my usb mic , and it seems to work correctly, even if ALSA is not set in the MIDI device configuration. But I am wondering if it has an impact on the quality of my audio files…

if MIDI configuration is not necessary for my use, I won’t spend time to try to install the timidity-daemon package.

No, not at all. If you are only using Audacity with audio, then MIDI is not required at all.

Just for completeness:

Sorry, I’d forgotten that error. It isn’t really important as it’s easy to work around. Timidity should have installed correctly, but the script that sets up launching the daemon fails (the script makes Timidity available as a background service). If you want Timidity to be available as a background service you would need to manually add an entry in “Session and Startup > Application AutoStart”. The required command is:

timidity -iA

Ok, so for my use, I will use audacity without MIDI.
Many thanks for your precise and complete answer !

This topic was automatically closed after 30 days. New replies are no longer allowed.