Problems downloading plug-ins

Hi everyone… Please excuse what may sound like a sniveling mopy myrtle but I’m getting to the point of major frustration…
Is there a program out there that doesn’t require constant upgrades and plug-ins that never work immediately? I just want to record. I ventured into audio books and see they have their own set of requirements. I tried to download the acx-check plug-in and low and behold it’s not showing up on analyze. I see the plug-in. It’s in the correct ~library folder. I’ve restarted my Mac 4 times and it’s just beyond annoying…
I just got fantastic help from you guys regarding the de-esser and I really don’t want to dedicate another 4 days of trial and error and wanting to throw my laptop into the fish tank…
Any helpful solutions will be much appreciated… I really like to know how to do stuff, I’m an independent person but when simple instructions don’t get and I’m spending more time figuring it out and less time actually doing what I want to do… like… just record, I get frustrated…
Please help. I’m about to explode at this point…
Maybe I’ll do like Myrtle and just splash down the toilet bowl LOL

I just want to record.

The longest posting on the forum is Ian who “just wanted to record” audiobooks from his apartment in Hollywood. 39 forum chapters and over a year. It appears that producing audiobooks should be easy and the microphone makers assure you it is.

It’s not.

It’s pretty common for downloads to add .txt on the end of a filter or plugin name by accident. This changes the filename enough so it won’t work. Control+Click or Control+Tap the file > Get INFO. Scroll down to the “real” filename. Change it there if it has the added .txt.

Even if you do everything right, you still have to enable the plugin with Analyze > Add Remove Plugins.

Either of those help?

It’s good if you tell us the steps you already did, particularly if you already installed a plugin.


Installing Nyquist plug-ins is much easier with the latest version of Audacity, as it has a “helper” that copies the plug-in to the correct location for you.

The current version of Audacity is 2.3.2 and is available for macOS via the Audacity website:

See here for how to install Nyquist plug-in on macOS:

:laughing: oh wow… I’m glad I’m in a familiar place. You guys on this forum are awesome. You are absolutely right. It did add the .txt at the end. I’ll adjust it now… Thank you thank you.

Oh yay… You guys are the best on this forum… Ok you’ve convinced me. I was going to hold off on the 2.3.2 but you twisted my arm. Do I need to delete the ACX-check first then update Audacity or just go ahead and update?

Just go ahead and update.

Screen Shot 2019-05-17 at 9.31.23 AM.png
Screen Shot 2019-05-17 at 9.30.43 AM.png
Screen Shot 2019-05-17 at 9.31.07 AM.png

In the Nyquist Plug-in Installer, click on the “Browse” button, then in the browser, select the plug-in that you wish to install.

Detailed instructions are here:

Yep I did see that and tried and that’s when that error message came up.
So then I put my brain into gear to try to find the file. It wasn’t an easy solution for me but I figured out how to find the file. I chose the Acx-Check.ny file and another error message.
I even moved it in the location box the installer was showing me… And… :unamused:

That’s not accurate. The error message came up when you clicked the OK button.
The reason that the message came up is because you had not selected the Acx-Check.ny file in the file browser.

Perhaps you have a friend that is good with computers to help you?

Sadly I do not. Hence my frustration. I’ll just keep on trying and reading until I figure it out.

Where is the file “Acx-Check.ny” on your computer? Is it on your Desktop, or in your Download folder, or somewhere else?

It’s now at my desktop

So I reinstalled ACX-Check and did not delete .txt. And it showed up in plug in management. I was able to enable it. I removed .txt earlier and for some reason I guess my mac didn’t like that. We have progress… Now trying the Nyquist installer…
Thanks all

ok I guess never mind. When I did tools, nyquist installer it said it’s already installed. So I guess I’m good to go now. wow… Thanks for your patience and help Steve. I’ll be so happy when I’m over this “don’t know hurdle”
I’m getting there.
Anyhoo… Thank you

It’s now at my desktop

I do everything through the desktop. It’s enormously easier than chasing files all over the machine. When the desktop starts to fill up, then I do the housekeeping—at a time convenient to me.

Here’s a trick. If you try to use Spotlight to find something, it will naturally assume you want to open whatever you found. While the search hit is hanging there in mid air, press and hold the Command key. If you hold it long enough, Spotlight will give up and show you where on the machine the file actually is.

I can’t take a picture of that because of conflicting keys, but it shows up in tiny text along the bottom.


I marshaled my forces.

Those are nested folders starting with the desktop. This is one place ISO dates come in handy. Today is not 5/17/19. It’s 20190517.

Later Macs move this around a little.


Are you hoping to read for audiobooks, retire rich and move to a nice cottage on the Mal d’Mer coast?