Problems between the audio interface and the laptop

I have earlier been able to record keybord and bass through audio interface (Behringer U-phoria UM2) into Audacity, but it does not work any longer: there comes only some distorted noise through. Problem remains even with different Audacity version, with Reaper, and with Windows 10 → 11.

When the headphones are connected to the AI, the sound seems OK, so the problem seems to be related to either the drivers, the sound card or the settings? There is and has always been only the internal sound card of the laptop, and I have tried older and newer ASIO4ALL-versions. I have tried different settings in the computer and in Audacity, but nothing seems to fix the problem.

I have limited experience with ASIO4ALL.

Do you have the same issue without this interface? I am thinking you should just be able to use Host:MME or WASAPI, then select the UM2 directly.

Thank you, jademan.
I have tried all those hosts, but none of them lets through the sound of my instruments. I also bought a used mixer to be able to try without the audio interface, but the result is still the same.

Interestingly, my microphone still seems to record my vocals normally through mixer and/or audio interface, so this is somehow an instrument-related problem.

Is your keyboard a MIDI keyboard? Audacity does not record MIDI signals.

No, it is not, but through USB-audio interface it was earlier easy to record it in Audacity. Also my bass guitar worked equally well through AI earlier, but neither instrument works any longer.

Actually there appear now some quality issues also with my microphone recording. My laptop is a cheap one, so should I try to buy an external sound card? Does anybody have any experience, if there is a chance that it could help?

This won’t be much help but ASIO4ALL won’t work with Audacity because Audacity isn’t an ASIO application.

I think the UM2 is “class compliant” so it should be plug-and-play with the drivers built-into Windows, macOS, or Linux.

ASIO4ALL adapts regular Windows hardware to work with ASIO applications, but it doesn’t adapt the software.

If you are still having difficulties, may I suggest uninstalling any ASIO drives you may be using - they may be interfering with the standard Windows audio architecture, and may be related to the issues you are having.

Thank you, guys. I removed ASIO4ALL, and the microphone recording works perfectly again. But the instruments still do not come through, except some distortion in the place of the start-attack of some of the notes played.

So you are making progress.

So this sounds like you have gain/signal level issues somewhere…

This topic was automatically closed after 30 days. New replies are no longer allowed.