Problem with re-enabling plug-ins since upgrade to 2.2.2

Yesterday saw the new update and installed in on my Windows 7 computer at my work. On this particular PC I’m restricted to not being able to run most Windows installers so I always update Audacity using the .zip files. As usual I opened the .zip and copied the contents to my existing Audacity directory. I am also restricted with read-only access to any directory other than User directories, including Program Files, and Program Files (x86). I am able to write to any User Directory including AppData. So as a workaround I have installed Audacity to c:(Username)\Downloads\Audacity_... In the past I had just followed the naming format as it is in the downloaded .zip file: audacity-win-2.2.1, audacity-win-2.1.3, audacity-win-2.2.2, etc.

In the past I would just copy the new files from the updated .zip to the existing audacity directory in my downloads directory and manually change the directory name to the updated version. audacity-win-2.2.1 changed to audacity-win-2.2.2 for example in this case. However, I’ve noticed that when I do that it causes the plugin config to get messed up, typically using the add/remove effects will show multiple directories for my VST effects, even when only the current directory actually exists.

Trying to load or use a plugin that is showing up under an incorrect directory will return a failure to initialize plugin error on attempt to load. So what I usually would have to do would be to only enable the effects in the current directory listing and manually disable those in any incorrect directories.

Since this most recent update I have started to get some specific error messages when attempting to add effects with add/remove effects menu. I’m attaching screenshots of the two errors. essentially they seem to be about the same:

Both say : Effect at :C:(User)\Downloads\audacity-win-2.2.2\Plug-ins\ (effect name).dll failed to register. The second error just includes additional information of : Could not load the library.

So in order to fix this issue I attempted to just rename the Audacity directory in downloads folder to “Audacity” and leave out the version number. I then deleted the pluginregistry.cfg and pluginsettings.cfg and attempted to re-add/enable the plugins using the add/remove effects menu. The plugins are showing as “New” under the current directory c:(User)\Downloads\Audacity\Plug-ins.

However, I am getting the same error messages when attempting to enable them. I am certain the plug-ins I’m attempting to add work with Audacity and my other DAW, Reaper, still has no problem with loading them (after updating the VST config path in Reaper to include the current Audacity plug-in folder path). So that would seem to rule out corruption or similar issue with the actual plug-in.dll files.

I have also attempted to delete all Audacity .cfg files, including Audacity.cfg, and then deleting the entire audacity folder in AppData as well. It works to reset Audacity to initial configuration, and when add/remove effects is called the paths for the plug-ins is correct and shows the changed Audacity directory: c:(user)\downloads\Audacity\Plug-ins). But enabling them and clicking OK causes these error messages to come up on every single plugin that I’m trying to enable. So far I haven’t had time to sit here and click OK on each and every one of them to see if can get through all the errors, the time listed is fluctuating up to many many hours, etc.

Anybody have any idea what the heck I can do here to be able to get plug-ins working again?

I have EXACTLY THE SAME issue. Whenever I’m trying to load my plugins, which works perfectly well in previous versions of Audacity, this error message occurs.

But there is one interesting thing - when I load every plugin that I want to use and close the error messages, I can use those plugins without any problem. So this error is a little bit weird.
plugin bug.jpg
I also wrote to the Audacity feedback contact email and I wonder what they will reply to me.

I’m not on Windows, so perhaps you guys could give some additional details. Does this issue only occur with VST effects?

Not sure if only occurs with VST. Guess really only other type on Windows would be LV2 or LADSPA?
Anyway, haven’t had time to sit here for an hour or more hitting OK for every single one of my plug-ins, but seems like that
is what it’s going to take to get all them working. Workflow comes to a screeching halt right now, so guess I’m going to have
to do that now.

This may help:

Try searching your computer for these two files:


Delete or rename any instances that you find. They are normally in


but I’m not totally clear how you have things set up.

Then, in the extracted program folder (the folder that contains “audacity.exe”), create a new folder called “Portable Settings”.
If this folder is present, Audacity will save its settings / configuration files in there rather than in AppData\Roaming

Thanks Steve. Good to know how to set up as a portable installation. Unfortunately, it didn’t resolve the errors. As lespaulplayer621 said, you can just click “OK” through the errors and after that the plugins show up and work as normal. It’s just quite a hassle to have to manually click “OK” for every single plugin.

I have tried to delete above mentioned files (pluginregistry.cfg and pluginsettings.cfg), but i didn’t work.

So as I wrote earlier, this must be some bug in Audacity itself. I didn’t have that issue in previous version of this DAW.

I’ve also noticed that there is problem with live monitoring of plugin effects, so you can hear how certain effect will work with your input signal unless you record something and then edit it.
So I thnk that the only way to resolve this problem is just wait for new release of Audacity, and that the developers of this program will repair this issue.

The only reports I’ve seen of this issue are the two cases here.
@ lespaulplayer621, you say you have “EXACTLY THE SAME issue”. Are you also using the ZIP version of Audacity 2.2.2?

What are the directories?

What do you mean by “live monitoring”? What exactly are you doing?

Ok so I am a windows user and I installed audacity today. I never before tried to use any plugins but I decided to give it a go and voila… Getting the same error as you were guys. But then it hit me… “Failed to register”… Hmmm… Shutdown audacity… Deep Breath… run audacity as ADMINISTRATOR… And tcharaaan… IT WORKS NOW! NO anoying errors.

Actually nevermind… It was just because i was loading the same plugin so the error didn’t show up on the second time… :frowning:

Yes, I’m using the ZIP version of Audacity 2.2.2.

I’m clicking on the Recording Meter Toolbar. Previously when I click that bar I could hear how my effect (i.e. amp simulator) will work, but now I can’t do that. So I can hear input signal, but without any change by the effect itself.

I’ve examined your method with running Audacity as an administrator. I’ve loaded some new effects and it didn’t work, so errors are still present. :confused:

Are you sure?
I’m not on Windows, but I’m pretty sure that in Audacity, effects only act on recorded audio (the audio in the selected audio track) and NOT on the live input stream.

The relevant section of the manual:

Thanks for your advice, it’s very useful. But I had been using plugin effects with real-time preview, not the onboard effects of Audacity. But this is not the case. The most important thing is that now this program can’t load new VST plugins correctly. And devolopers of Audacity should work on that problem.

And by the way, I 've made one mistake in one of my previous posts. I wrote that I’m using ZIP version of Audacity. This is not true. I’ve checked it a moment ago and noticed that I have normal version of this DAW.

You started off by saying that you had “EXACTLY THE SAME issue” as ericb7799, which turns out to not be the case as you are using a different version of Audacity, installed in a different location, with different plug-ins and different symptoms.

The first step when troubleshooting any technical problem is to clearly identify the problem. There can be no serious attempt at “fixing it” until the problem has been clearly identified. We are now on the second page of posts, and I am little clearer about what the problem is than I was at the start, though it appears that ericb7799 has a workable, albeit tedious solution. Are you able to “click through” the problem as ericb7799 described?

Yes, I can do it. Also, to be precise, this is not solution invented by ericb7799, but by me. I have noticed that it is possible to click through all error messages and erib7799 confirmed that it works for him too. And when I said that I have “exactly the same issue” I meant that I have the same error messages in the same situation. Maybe other circumstances are different for me and the other users with that problem, but I think that the essence is similar.

By the way, if you want I can send you my Audacity debug report and the log file, which I generated after I ran across that problem.

Was doing some troubleshooting in my AppData/local/Temp directory and found some
Audacity crashlogs and debug reports that may point to a cause of the problem.
At least from my (mostly)untrained eye appears to relate to a problem loading some
of FFMPEG components when FFMPEG is not in PATH. Here are a few excerpts:

:31:30: Checking that ‘C:\Users\vhaglabruceed\Downloads\FFmpeg’ is in PATH…
12:31:30: Warning: FFmpeg directory ‘C:\Users\vhaglabruceed\Downloads\FFmpeg’ is not in PATH.
12:31:30: Temporarily prepending ‘;C:\Users\vhaglabruceed\Downloads\FFmpeg’ to PATH…
12:31:30: Checking for monolithic avformat from ‘C:\Users\vhaglabruceed\Downloads\FFmpeg\avformat-55.dll’.
12:31:31: Error: Couldn’t find symbol ‘avutil_version’ in a dynamic library (error 127: the specified procedure could not be found.)
12:31:31: Error: Couldn’t find symbol ‘avcodec_version’ in a dynamic library (error 127: the specified procedure could not be found.)
12:31:31: avformat not monolithic
12:31:31: Loading avutil from ‘avutil-52.dll’.
12:31:31: Loading avcodec from ‘avcodec-55.dll’.
12:31:31: Loading avformat from ‘C:\Users\vhaglabruceed\Downloads\FFmpeg\avformat-55.dll’.
12:31:31: Returning PATH to previous setting…
12:31:31: Actual avutil path C:\Users\vhaglabruceed\Downloads\FFmpeg\avutil-52.dll
12:31:31: Actual avcodec path C:\Users\vhaglabruceed\Downloads\FFmpeg\avcodec-55.dll
12:31:31: Actual avformat path C:\Users\vhaglabruceed\Downloads\FFmpeg\avformat-55.dll
12:31:31: Importing symbols…
12:31:31: All symbols loaded successfully. Initializing the library.
12:31:31: Retrieving FFmpeg library version numbers:
12:31:31: AVCodec version 0x373466 - 55.52.102 (built against 0x373466 - 55.52.102)
12:31:31: AVFormat version 0x372164 - 55.33.100 (built against 0x372164 - 55.33.100)
12:31:31: AVUtil version 0x344264 - 52.66.100 (built against 0x344264 - 52.66.100)

Those FFmpeg messages are normal. It’s just logging the search.