problem with plugin Manager [SOLVED]

Hello.
(I use audacity 2.1.1 under Windows 8)
I try to install the following plug-ins: harmonic gen 1220/ladspa-util/ libfftw3f-3/ logarithm/Phasm2 (VST Novaflash).
I tried several times. Having to click on “OK” in the plugin manager, the scan dashes. But he does not succeed. This plug-ins never appears in the column: Effets/LADSPA or Effets /VST.
It is necessary to delete "pluginregistry.cfg?

You need to click on the “Enable” button to enable the selected plug-ins. (see: http://manual.audacityteam.org/o/man/manage_effects_generators_and_analyzers.html)

Thank you.
If I clic on “Enable”, then “Ok”, a scan of plug-ins seems to launch. Then the plug-in Manage closes.
But, if I loock in the plug-in Manage after, the plug-ins which I wanted to add are always considered as “Nouveau” (State).
If I look in the pluginregistry.cfg, I see: Symbol = 0 Name = 0 Version = 0 Vendor = 0 Description = 0 Enabled = 0 Valid = 0

Yes that sometimes helps.

libfftw3f-3/dll is merely a DLL that enables libfftw for the few LADSPA-swh plugins that need it.

harmonic_gen_1220.dll appears for me in the Effect menu as Harmonic Generator.

As previously requested, please give links to other plugins that may be causing problems.


Gale

Hello.
Problem with plug-in Manager (continuation).
I placed the plug - in “ExperimentalSampleDataImport.ny” in the file “Plug-ins” of “Audacity”, In Audacity 2.1.1 under Windows 8.
I clicked " enable " in the plug - in Manager. I clicked on “OK”. Now this plug - in does not appear any more in the list of the plug in Manager.
If I open the file " pluginregistry.cfg " I see at the level of this plug-in " EffectInteractive = 0"
A user has he already observed this problem?

It sounds like Audacity has disabled the effect so it is probably a problem with the plugin and not the plugin manager.

Did you get this plugin from https://forum.audacityteam.org/t/importing-text-as-audio-exporting-audio-as-text/21905/17 Have you modified it? I suggest you attach the exact plugin you are using.

Gale

Hello.
I downloaded this plug-in on the official site (Forum Nyquist) . I did not modify it.
ExperimentalSampleDataImport.ny (1.16 KB)

Open the file in a plain text editor such as NotePad.
Add a space at the end of the line:

;control file "Input file" string "" ""

then save the file.
Ensure that the file name still has the “.ny” file extension.

Hello.
Thank you .
I have a precision to be asked. It is necessary to place a space enter … string “” (here) “”, or … string “” " (here) "?

Add a space at the end of the line.

This plugin is listed in “All” in the Plugin Manager as “Sample Data Import” after you have enabled it and clicked OK. Before OK, it is listed as “ExperimentalSampleDataImport” as per the file name.

Without making that change, the plugin appears as expected in the Generate menu, after enable and OK in the Plugin Manager (I am on Windows 7 x64 at the moment).

But the effect’s interface does not appear until you add the space. Can we add the space in the file we offer for download?

The space must be placed at the end of the line.

;control file "Input file" string "" ""SPACE HERE

I would make edits to NY files in Notepad++ or some editor that can show the line ending symbols. It is then much easier to see what you are doing.


Gale

Thank you very much.
The problems are solved.
Now, I go tried to create sounds from files data. This strange subject is evoked by users of Audacity.