Problem with playback through audio interface (os 10.9.5)

I’ve recently started using audacity again for when I quickly want to capture something, but I can’t listen to what I’ve recorded in audacity due to a clicking/stuttering sound.
So I don’t have to explain what it sounds like, I’ve captured a short click of a vinyl rip (this recording was in 24bit 96kHz) on my iphone.

It sounds to me like a clocking problem, but I can’t seem to figure where the problem seems to be. The problem is in the combination with audacity and my audio interface, since it doesn’t occur in any other case:

  • recording and playback in logic works fine
  • playback in logic of what I’ve recorded in audacity works fine
  • playback in audacity to the build in logic (or any other program) output of my macbook works fine
  • playback of anything (movies/music/whatever) through my audio interface works fine

I’ve tried audacity on 44,1kHz, 48kHz and 96kHz (always changing the setting on my audio interface too and checking that is correct in audio/midi configuration)
Material I use:
audio interface: edirol Fa-101
Audacity 2.0.6 (i had 2.0.5 before which also had the same problem)
Mac os x 10.9.5

Any help is greatly appreciated!

Thanks for the excellent report, though I wasn’t clear what you meant by

Do you have latest firmware and drivers for the Edirol?

Do you have an empty or partially empty track above what you recorded, if so does it help to mute or remove that empty track?

Can you please try the latest 2.1.0-alpha from the top of That has a fix that always resets the playback buffer.


This was just meant to read “playback in audacity through the built in output of my macbook works fine.”

I tried you’re suggestions, but they did not help
I have never installed drivers for my edirol, and I just checked roland’s website, but there are no drivers for my audio interface for mac os x
I only have one (stereo)track in these recordings, I quickly recorded an empty track, put it above the other one, muted it, deleted it, but none of that changed anything.
I also tried the latest alpha build but that did not solve the problem either.

Can you make out what sort of defect I’m getting from the audioclip I posted? Otherwise I could record one where it is a lot more audible


On it says that Edirol drivers are not needed for your version of OS X, but

Please visit to download the latest standard FireWire audio driver in the Mac OS X update supplied by Apple Computer

I guess that just means, make sure you are fully updated with system updates.

I can hear it, but it doesn’t help diagnose it, given it isn’t the problem directly addressed in 2.1.0-alpha.

Have you tried changing Audio to buffer in Audacity’s Recording Preferences? And/or looking at any accessible buffer settings in Edirol? Perversely, reducing Audio to buffer below default 100 ms in Audacity can often help.

Have you tried turning wireless off?


I played around with the buffer for a bit, higher, lower, tried to match the settings logic has, but none of this made any difference.
I also tried it without wifi but that not change anything either.

I did however find a way to make the sound stop. I converted the recording to 16bit PCM and that solved it. This is however not a permanent solution for me, since I need recordings in 24 bit. Do you have any suggestions on what settings to look at/change on the basis of this? (again playback in 24bit works in logic, and there is no problem with recording in 24bit in audacity or logic). I double checked the audio/midi configuration and that was set for 24bit.


Where did you convert the recording to 16-bit PCM - in Audacity’s Track Dropdown Menu? If so, yes that’s odd that it would crackle as a 24-bit track sent to Edirol set to 24-bit output, but not if you send a 16-bit track. It would suggest (perhaps) that using Audacity, the quantity of data processed affects playback. It could equally be Edirol or Mavericks bugs that Audacity is exposing, or a Mac-only Audacity bug.

You could try a couple of things. If you have Audacity’s Quality Preferences set to 24-bit, try 32-bit float instead.

Otherwise (assuming you are not recording overdubs), try setting the Output for Edirol in Audio MIDI Setup to 16-bit, but leave the input at 24-bit.

If that doesn’t help, you may perhaps want to ask on the Apple forums or Edirol support to open up other lines of enquiry. Also we could ask a developer with an external device on Mac to see if they can reproduce the problem, but as far as I know no developers have your device.



We also have a issue that sounds very much like yours only for us the static that you hear in the recording is actually recorded to the file, and will be present when played back through other software. It usually starts after long periods of recording, mostly after 15 minutes.

We have updated the divers and firmware for the Motu Audio Express.

Changed buffers
Changed Sample Rates
Checked clock
Re installed software,
Repaired permissions.
Deleted Preferences.

We’re running the latest version of Audcacity.

The issue is isolated to Audacity, other software records without glitch.

Mac Mini Late 2012 Firewire > Mote Audio Express.
Mac OSX 10.9.5
Latest Audacity.

For the sake of clarity please look at the pink panel at the top of the page and give us the exact Audacity version number - all three numbers.

If you have not already done so you could try the latest 2.1.0-alpha build from the top of That might help if you are recording into tracks that had previous content. 2.1.0-alpha is believed stable and should be close to ready for the upcoming 2.1.0 release.

Have you tried reduced Audio to buffer in Audacity’s Recording Preferences? Take it as low as it will go that allows you to record.

Resetting Audacity Preferences requires more than reinstalling Audacity. To reset preferences, quit Audacity, open Finder, choose Go > Go to Folder and type:

~/Library/Application Support/audacity/

In that folder, open the audacity.cfg settings file. Select all the text and delete it. Then type the following at the top of the file:


Save audacity.cfg and restart Audacity.

Also have you rebooted the computer recently? If not, please try that.