Problem with piano sound

Hello, I’ve been recording my piano audios with Audacity for years, but I recently changed my laptop and today I’ve found I’m not getting the right sound. Instead, I’m getting this one:

My piano is a Yamaha p-155 and my audio interface device is a “Native Instruments Audio Kontrol 1”, but other things have changed:

- Laptop: I had an HP, now I have an ASUS. I don’t think this change has anything to do with the problem.
- Audacity version: I used 1.3.x and now I have 2.1.0. I’ve tried installing the old version, but the problem remained, so I remove this option.
- OS: I had Windows 7, now I have Windows 10. I suspect this could have something to do with it, but I don’t know what it is or how to solve it.

Any ideas of how can I solve it?

It’s difficult to tell what the problem is from that sample because of the low quality of YouTube sound.
Could you post a similar short sample in WAV format direct to the forum. See here for instructions:

The problem is that it sounds the same as the YouTube video precisely. You can compare with any of my other videos to hear the difference, here is an example:

Anyway, here it is the link to the wav:

It’s not unusual for sound equipment on Win10 to require updated software and drivers.


yes, but it ‘looks’ quite different when zoomed in close, and now we can see why it sounds terrible:
As you can see, every seventh sample is at “zero” (on the centre line).
I’d guess that the most likely cause is the sound card drivers.
Go to the ASUS website and find the latest drivers for your new laptop. Note that the drivers must match your exact model of computer and the version of Windows that you are using. Their website is here:

My card is an external one as I said, Audo Kontrol 1 by Native Intruments. It’s true that I initially installed the drivers from the original CD, but now I’ve uninstalled everything and reinstalled the latest version I’ve found in their website, and the problem continues… I mean, every other sound in the computer is fine, even when I play the piano through the device via audio sounds fine in my headphones. It only happens when I record the sound in Audacity, then the recorded audio changes.

But as you can see from, the latest AUDIO KONTROL 1 Driver 3.1.0 only supports Windows 7, 8 and 8.1 - not Windows 10.

Are you using that AUDIO KONTROL device because your computer lacks a line-in?

You can use something like the Behringer UCA 202 instead:

Or I understand you can record the song directly on the keyboard, then transfer the file to computer by connecting a USB drive to the correct USB port of the keyboard that is meant for that purpose.


I saw that too, that’s why I decided to uninstall the whole thing and install the full version that’s in that site (AUDIO KONTROL 1 Full Installer 1.2.5 - Windows) which comes with the latest drivers. What I don’t understand is why is everything working fine with the device except when I record with Audacity, I find that very weird. If the problem was in the device, I would hear the bad quality sound while playing the piano in real time too, but that doesn’t happen.

I wanna try to solve this before considering buying another card. The USB option could be useful and I will try it, but I don’t wanna give up on this device or on Audacity that soon…

I also wanna thank you all for all the help you’re giving me, you’re awesome ^^

But the date of that is claimed as “10.05.2010” - years before Windows 10 was released.

Because recording is more demanding and more susceptible to driver errors than playback.

As a test, you can record in “Voice Recorder” that comes with Windows 10. Just make sure AUDIO KONTROL is the default Windows recording device in Windows Sound. To open the app, press Windows Start, type “recorder” (without quotes) then press ENTER on your keyboard. Click or tap the microphone icon to start recording, and click or tap the Stop button when you’re done.

Does that show the same problem?


Oh, I see, then the driver test is not valid, it can still be that problem,
As for the voice recording, It works fine. In fact I usually do it with OSB (Open Broadcaster Software) and it hasn’t been any problem so far.

I tried the USB option, but I didn’t know the file that comes is a MIDI file. I’ve never worked with MIDI, that’s why I have a good piano that lets me work with audio directly (I also don’t have any program that supports it).

But did you record the keyboard through AUDIO KONTROL using Voice Recorder? Or can you try some other application than Audacity to record the keyboard? If that records OK, we can make some other suggestions of settings changes you could try.

You mean you saved your recording on the keyboard then transferred it to the computer? MIDI can sound bad or good according to the MIDI Soundfonts you have installed.

But you may have to buy a more generic USB audio interface like UCA 202.


Try increasing the buffer: Edit → Preferences → Recording → Latency.

You might have a “bad” driver, or it could be another driver or application that’s hogging the CPU.

Make sure you’re not running any other applications, and you might have to reduce any background operations. Some people recommend temporarily turning-off your virus protection or disabling Wi-Fi.

The idea is to minimize interrupts or to use a bigger buffer so you can capture for longer period of time between interrupts You can’t eliminate interrupts because that’s how a multitasking operating system works, and even when you’re running only one application the operating system itself uses interrupts.

[u]Here is a free e-book[/u] about optimizing your computer for audio.

Oh, yesterday I somehow thought you referred using a microphone as it was a “Voice” Recorder, and that worked fine. I’ve just tried recording the piano through AUDIO KONTROL using Voice Recorder and sounds ugly as well, that’s unfortunate.

The piano has an USB port. I used it to save 1 song data in a pendrive and the file is a MIDI one. But my goal is to keep recording the Yamaha audio directly, so I have no plans to work with MIDI.

OK so you can be satisfied Audacity is not at fault, if the problem is the same with every seven samples silenced. That looks more like a driver problem than the computer not keeping up. You could try a different host choice in Device Toolbar but it probably won’t make any difference.