Problem when using Headphone option

I get “Error Opening Sound Device” when Audacity preferences are set to HeadPhones and the headphone jack is subsequently unplugged, even after plugging the headphones back in again, as if it fails to recognize that the headphones have been reconnected. This error consistently happens. I have tried to switch preferences to internal speakers and back to headphones but the problem is not fixed until you quit Audacity and restart it with the headphones already connected, which is annoyingly disruptive when in the middle of a large project. Applications other than Audacity work with no problem and also correctly switch automatically from internal to headphones according to whichever device is connected.

Audacity version 3.3.2 on Macbook Pro 16" 64GB Ram, Apple M1 Max. OS macOS Monterey v12.2

Do you have a setting for making your headphones the “default” input device in you macOS.
I windows there is a setting for default.
All your devices should be listed in Audacity if working…In windows it just a matter of picking them

Plug in the headphones, the do Transport (menu) > Rescan Audio Devices, then select the headphone from Audio Setup (on the Audacity toolbar) > Playback Device. At least you don’t have to quit and restart.

Thanks billw53, that tip worked! Now it’s a minor inconvenience but no longer a major disruption

This topic was automatically closed after 30 days. New replies are no longer allowed.