Problem recording 24-bit with Roland Quad-Capture


I’m running Audacity 2.0.3 on Windows 7 with an external USB recorder, a Roland Quad-Capture.

But I fail to sample with 24 bit precision in Audacity (although I can do this in Sonar X1 LE that came with Quad-Capture).

I have no apparent problem setting 24-bit i Audacity, and when I record there are no error messages. But when I store the recording as a 24-bit WAV and open it up in a signal analysis program (MATLAB) the recording is quantized at the levels 0, 256, 512, and so on, which clearly indicates that the 8 least significant bits (bit 16 to 24) are zero and not used.

Any clues?

Wild stab. The device requires special software that is supplied by the program that came with it. Audacity relies on Windows drivers and they do not natively support 24-bit. Someone will correct me. Koz

Audacity uses Portaudio to communicate with the sound system. Portaudio does not accept greater than 16 bit from MME and DirectSound hosts, so regardless of your hardware, if you use MME or Direct Sound you will get a maximum of 16 bit.

Portaudio supports 24 bit with ASIO and WASAPI, but Audacity can not be shipped with ASIO support due to licensing restrictions and WASAPI is not yet supported in the release version of Audacity.

WASPI support is currently in development - I think it’s current status is “experimental”, but it IS available (at your own risk) in the latest nightly build of Audacity (note that nightly builds are snapshots of the current development code and are not official releases).

There are currently some unresolved issues with WASAPI that may (or may not) affect you if you want to try the nightly build:
You may sometimes get “Error Opening Sound Device”, and you may find latency is low at first but then becomes higher. There was also an issue with slow launching of Audacity but I’m unsure if that has been resolved or not.

If you wish to try the nightly build you will want the one that is at the top of the list here:
Quit Audacity, extract the downloaded zip file to any location on your computer then run “audacity.exe” from the folder you extracted to. Select the “Windows WASAPI” host in the first box of the Device Toolbar.

If you do try this, please let us know how you get on with it.

Thanks Steve, I appreciate your answer very much.
I downloaded the experimental version as you proposed, and it works just fine for me. I can now record with 24-bit precision!

Are you getting any of the issues that I mentioned?

That issue has been around for a long time, but the WASAPI-enabled builds do take about one-third longer to launch compared to 2.0.3 Release.

Another issue that came in with the changes for WASAPI on Windows is that launching Audacity may interrupt any audio playing on the computer for a few seconds. This is irrespective of which host you actually have selected in Device Toolbar.


Several of the entries state that audacity does not ship with ASIO drivers. I just got a Prism Lyra I USB interface/ADC - but it only recognizes asio.
The JRiver Media Center player is OK with whatever asio drivers are on the computer - but audacity doesnt recognize any of them.

any solutions?

As it says in the Frequently Asked Questions:
“Licensing restrictions prevent us including ASIO support in released versions of Audacity, but Audacity can be compiled with ASIO support for private, non-distributable use. See ASIO Audio Interface on the Wiki for details.”

If you have further questions, please start a new topic.