Problem converting 24-bit FLAC to 16-bit FLAC


I am jumping on this thread because I have been attempting to convert flac files @24/92 to flac files @16/44, using project rate command and export file to flac, but each time the output file is corrupted : it has twice the playing time of the original file, and when you play it, it just sounds as if it was played too slow.

I have read about dithering or not, but can’t find where this setting is in audacity.

I am running audacity 2.0.1 on Linux Mint 13.

Thanks for any feedback.

Best regards,

It’s better to start a new thread even if searching found a partially relevant thread. I’ve started a new topic for you. You are almost certainly not on the same distribution as the original poster, nor are you asking the same question.

Please write out sample rates and bit depths rather than use abbreviations. Even if we can guess what you mean, other users may not be able to.

If you mean 24-bit at 92000 Hz, then 92000 Hz is a non-standard rate. I would recommend 96000 Hz instead.

Using our 2.0.4-alpha development build on Ubuntu 13.04 with a 24-bit source file at either 92000 Hz or 96000 Hz, I cannot reproduce a problem. Have a look in Help > About Audacity, on the “Build information” tab, under “Core Libraries”. Which sample rate conversion library is enabled? 2.0.4 uses libsoxr by default.

2.0.1 is an obsolete version of Audacity, and isn’t provided by us, assuming you are using the Linux Mint package of Audacity. Linux Mint packaged builds of Audacity sometimes have strange problems, so using them is discouraged. Linux Mint is not a good distro to choose, because it is not as simple to build Audacity yourself from our sources on Linux Mint as it is on for example Ubuntu.

Please see .



Thanks for the tips, by the way I wrote my message too fast so here is the good data :

Converting 24 bits 192 khz to 16 bits 44khz flac files is what I am trying to do with audacity 2.0.1 running on linux mint 14 and using libsamplerate library.

I agree with you about the Mint distro, and I would not recommend it to a rookie as I am, but would prefer Ubuntu (maybe I will make the jump one of these days !). For the time being, is there any way I can update to a newer version of audactiy under Mint 14 ?

Best regards,

Audacity does not directly convert files from one format to another. Audacity imports files into an Audacity project and the Audacity project may then be exported to create a new file which may be in the same format, or a different format. Thus there are two stages to the “conversion” process - importing the file into an Audacity project, and exporting to a new file.

When you import the 24 bit 192 kHz FLAC file into Audacity, does the project play correctly?
After importing, the project rate in the lower left corner of the main Audacity screen should show 192000. Change that to 44100 and check that the project still plays correctly.
Then try exporting in the default “WAV” format.
Does the WAV format play correctly in your default audio player?
If it does, go back to the Audacity project and try exporting as a FLAC file - check the “Options” setting in the Export dialogue and ensure that it is set to 16 bit. Enter a new name for the file and export it. Try playing the file in your default media player - does it play correctly?

You can try Mint 15 which is the latest release from May 2013 . If it had the latest Audacity version current at Mint release it would have Audacity 2.0.3. Assuming Mint had not changed the default resampling library, that 2.0.3 would use libsoxr for resampling.

Otherwise you can try downloading our 2.0.3 source tarball or 2.0.3 tagged release ( ) then compiling Audacity using these steps: . I would suggest the tagged release - when I tried this with the tarball in a previous Mint release, I had to manually download a lot of Audacity dependencies which Mint don’t supply and download libraries that those dependencies depended on.


I happen to have a 2.0.4-alpha build that uses libsamplerate but there is no problem with import and export of a one minute tone at the bit depth / sample rates you mention most recently. I used libsndfile to import the FLAC which is default.

If there is still a problem, please look at Help > Show Log… and check whether libflac or libsndfile is used to import the 24-bit 192000 Hz file.