Presonus Firewire Stutter?

I’m using OSX 10.9.3 on a 2013 Mac Pro interfaced for playback over firewire (Thunderbolt to FW800 Apple adapter cable) to a Presonus StudioLive 16.4.2AI.

Audacity playback stutters like crazy. Audition is fine, iTunes is fine and VLC is fine.

If I start another audio application like VLC (in record) or Audition, the audio from Audacity sounds clean. Is there a missing part in Audacity? Maybe to do with timing? Audacity works fine with the CoreAudio Line output.

I saw a post about setting Audacity’s Audio Buffer preference and moved it from the default 100 ms to 300 ms. This fixed the problem for about a minute.

I’m on Audacity 2.0.6-alpha-Jun 1 2014 now. I was on the current release version before that but I thought there might be updates to fix this problem. Not the case.

Right now I just run Audition and that fixes Audacity but I can’t believe that’s the right solution. I don’t know if it’s just a Presonus problem or if it’s a problem for firewire interfaces in general. I’ve upgraded the firmware in the Presonus to the latest That didn’t help either. Everything is set to 44.1 Ksps.

Anyone else seen this problem?


Mac Pro and not MacBook Pro? There is an old-news problem with Mavericks and Audacity on MacBook Pros where the aggressive power saving features would cause problems.


Most users here won’t know what that means. I assume “sps” is short for samples per second and that Audacity project rate bottom left is 44100 (Hz).

If you are playing multiple tracks, make them all start at time zero or generate silence in the entire white space before the track starts.

Also try a very low Audio to buffer setting like 30 ms.

Many portable Macs turn the audio subsystem off after 20 seconds of inactivity. In MacBook Pro this has been reported to cause Audacity to not play at all if another application plays sound before Audacity does. So your symptom is not really the same but could be related - Audacity can’t restart the audio subsystem properly.

Do you have to be playing audio in other apps to produce clean playback in Audacity, or just running the other app? You may also find that opening Sound in the System Preferences and clicking the Input section may cure it - a few people have reported that.

Also try Audacity 2.0.2 and 2.0.3 from Google Code Archive - Long-term storage for Google Code Project Hosting. . Are either of those versions free from stutter?


I suppose 44.1 kHz is the rate at which it gathers samples… It’s not very descriptive though. :wink:

Not a Macbook Pro. It’s a Late 2013 Mac Pro. The shiny black mini trash can design.
3.7GHz Quad-Core Intel Xeon E5
16GB 1866MHz DDR3 ECC - 4X4GB
256GB PCIe-based Flash Storage
Dual AMD FirePro D300-2GB VRAM

The audio chain is [Mac Pro]<–Apple Thunderbolt to FW800 cable–>[Presonus StudioLive 16.4.2AI]<—Balanced Analog Stereo—>[Powered Monitors]<—[ears].

There are multiple tracks but usually not more one stereo pair are playing at one time and most of the time it’s just a single mono track (I do an old time radio show). I time shift tracks a lot to get them in the right places and I cut commercials and junk out of the middle. Keeping all the tracks padded with silence and starting at sample 00:00:00s00000 is going to double my editing time.

No, the “helper” app doesn’t have to be playing anything to make Audacity happy, it just has to be an active process. I kind of think that there is something that Audacity isn’t initializing that the other programs do. If, whatever that is, gets done by something else Audacity works find, other wise it never gets done and the stutter happens. My guess is that Audacity isn’t setting a clock source option somewhere it should be. Like an elastic store running out and recentering. There was some “feature” that doesn’t load things before they’re needed to make the start up faster. I think there might be something it doesn’t think needs to be loaded that really does in my configuration.

I did check the “App Nap” setting for Audacity and it’s set to “No”.

I loaded 2.0.2 and ran it. It works fine without a “helper”

Thanks, Bill

Then the Audacity Project Rate bottom left should be set to 44100 Hz to match.

You said off the Forum that before the problem started you used to have a first generation Intel Mac Pro that could only run Lion, with a MOTU Traveler interface. Were you using Audacity 2.0.4 or 2.0.5 with that setup?

The majority of recent Audacity’s audio problems seem to have started with Mavericks.

The playback problem with tracks starting with white space may or may not be part of your problem (the problem can affect other OS X versions than Mavericks).

If starting white space is the problem, you may be able to stop the crackle if you move any track that starts at zero to the uppermost track(s). If you mute all the tracks that don’t start at zero, the remaining tracks should play OK.

Well at least that gives you an easy workaround in 2.0.5. You can add an audio application to System Preferences > Users and Groups > Login items.

If you get a chance, could you try 2.0.3? (Make sure the running Audacity version is quit). Most of these problems started in 2.0.3 or 2.0.4 but users differ as to which versions are affected.



I was probably back a version on the old system but probably 2.0.3 or 2.0.4. I know I wasn’t too far back.

I did do a test with just a single stereo track imported to a new project and it stuttered.

I’ll load 2.0.3 and see if it has a problem and get back to you. Are there other diagnostics or system reports I can get that will help determine the problem?


I tried 2.0.4. Works fine.

I just re-downloaded a fresh copy of 2.0.5, just make sure something didn’t get messed up somewhere. Put it in a separate place from the original and tried it. The stutter was right back.

So, something significant to this problem changed between 2.0.4. and 2.0.5.


Thanks for the information. This seems like a unique case. The nearest issue similar to it (where you touch the input side in system Sound to restore sound to Audacity) has been said to occur in 2.0.4.


Not a unique case, we have the same problem. 24" iMac model A1225, running OS/X 10.9.5. We’ve got Audacity 2.0.5 trying to output through a StudioLive 16.4.2, and it stutters exactly the same. We haven’t found any solution yet.


What I meant by “unique case” was that 2.0.4 does not have the problem but 2.0.5 does. Where these problems occur, users usually say that 2.0.4 has the problem but 2.0.2 or 2.0.3 does not.

There are several possible workarounds in this topic. Have you tried those? Have you done the most basic thing (set the sample rate for the Studio Live in Apple Audio MIDI Setup to the same rate as the project rate in Audacity)?