popping noise when recording w/ USB mic [SOLVED]

I am running Audacity 2.1.0 on mac OS 10.9.5 on a macbook pro (13inch, mid 2012. 16GB ram, 280GB free disk space).
I have a Zoom H2 connected by USB to the USB port on the macbook (i.e. not thru a hub). the H2 is in microphone mode, at 44.1kHz sample rate.
Audacity is set to 16 bit, mono, 44.1KHz (same as H2), buffering to 100ms. (I have also tried 50ms of buffering)
overdub is checked, though when I experienced the problem there were no other tracks, so nothing to play back.
real time sample rate converter, medium quality. dither, none.

When I record all is well for about 15 seconds, the recording is just fine. Then I start getting popping noises that continue, at varying amplitude, throughout the rest of the recording. If this forum allows it, I will attach an MP3 of a recording, and a screen shot of the waveforms.

I do not believe the H2 is causing the problem because I can, using garageband, monitor the microphone when it is not recording and I do not hear the popping noise, no matter how long I monitor it.

Obviously I’m looking for a solution.

The H2 works OK in garageband – most of the time. However, sometime, even in garageband I get similar popping noises, though when that happens they occur continuously and if I switch back to Audacity, they are also continuous (and much worse) in Audacity.

Anyway, I’m not sure this is an audacity problem. It could be my macbook, or the mic, or some other issue.

that said, I’m hoping that someone here has some idea of how to deal with the problem.



Try a much lower Audio to buffer in Audacity’s Recording Preferences. Start from 0 ms. Go up in 10 ms increments until it records properly then use that lowest possible value.

If you have not done so yet, open /Applications/Utilities/Audio MIDI Setup and set Zoom to 44100.0 Hz 1ch 16-bit (or 24-bit if 16-bit is not available).

Turn overdub off unless you need it on.


Many thanks for the quick response and for the suggestions. The buffer seems to be the issue.

First, my midi setup was already as you suggested and, just for the record, I extracted audacity from the DMG and installed to the Applications directory.

I went thru several combinations of overdub on/off, buffer 100ms/0ms, latency -93ms/0ms. Each time I set the preferences, then exited audacity and restarted. when I recorded there were no other tracks present in audacity and no other music applications were running. firefox and mail were the only other apps running, and activity monitor showed little activity of any kind other than audacity.

With overdub on, buffer 100ms, latency -93ms, the noise started around 15 seconds into the recording. It varied a few seconds, sometimes as early as 12 seconds, sometimes as late as 18 seconds.
With overdub off, buffer 100ms, latency -93ms, the noise started at 45 seconds into the recording. (seems odd overdub had an effect since there were no other tracks and therefore nothing to overdub).
With buffer at 0ms, and all settings for overdub and latency, there was no noise. total recording time was 1minute 15 seconds.
(note: latency setting had no effect, which was not unexpected).

with buffer 0ms and overdub on, I was also able to record, without noise, when two other tracks were playing back during the recording (which is how I intend to use audacity for this project). That recording was 5 minutes long, so I think its fixed.

one question. Why do I need a buffer setting other than zero? what does the buffer do for me? I am willing to experiment with buffer settings other than zero, but I’d like to know why I need it.


Audio to buffer changes as soon as you OK preferences - there is no need to restart Audacity.

When you record, the incoming data fills up a length of audio called a buffer. The operating system comes back every so often to grab a chunk of this and pass it to Audacity. When you play audio, the buffer is a chunk of audio data waiting for the computer to send it to the sound card’s output.

The Audio to buffer setting determines the length of audio in the buffer.

In theory a buffer setting of 0 ms makes no sense, as it implies the computer could continuously and immediately process the audio as if it had no other tasks to do. However the Audacity setting can operate in context with other buffer settings for example imposed by the audio device or by audio subsystems.

It seems the problem where the Audacity Audio to buffer setting is too high started on most machines with Audacity 2.0.4. That Audacity version had an update to the PortAudio Audio input/output interface we use that reports much lower latencies than are reported for the same devices in Audacity 2.0.3. There is very likely a connection.

So basically if either 0 ms of 10 ms work for you, you can choose either. 10 ms (if it does not cause clicks) would in theory be safer if your computer was very busy and you were for example encoding a video and doing a Time Machine backup at the same time.


thanks, that’s a very clear and helpful answer.

I consider this closed, I’ll close the thread if I can figure out how to do it.

OK, I have marked the topic [SOLVED] and locked it.