Popping noise recording from cassette tape [SOLVED]

Audacity 2.0.3 .exe installer on Win 7 32-bit, recording via “ezcap USB cassette capture”. Setup is MME, MS Sound mapper input and output, mono with Software Playthrough, project rate 44100. I get a fairly loud popping noise 2/3 times per second on sound playback and on the recording. The recorded sound seems OK apart from the popping noise. Any suggestions welcome. :slight_smile:

Do you hear the popping while recording? If so, try a different USB cable, and experiment with a different “Audio to buffer” setting at Edit > Preferences… , Recording section. On Windows, you might need to increase “Audio to buffer” above the default of 100 milliseconds.


Gale

Try [u]inreasing latency[/u].

And/or if possible, don’t run any other applications while recording. Some people find it helpful to temporally disable their anti-virus and/or Wi-Fi if it’s a laptop.

Usually this is buffer overflow, especially if it’s periodic.

Even when you are only running one application, your multitasking operating system is always doing things in the background (such as updating the screen & clock and checking for keyboard/mouse input, etc.).

The analog audio flows-in and gets digitized at a smooth-constant rate… It flows into a buffer (like a holding tank) and when the operating system gets around to it, it reads the buffer in a quick burst and sends the data to your hard drive.

If some other application is hogging the CPU & data bus, or the operating system just doesn’t get around to reading the buffer in time, you get buffer overflow and a glitch.

A larger buffer (and the associated longer latency) helps in these cases.

…There is also a playback buffer, but it gets filled in quick bursts, and the audio comes-out at a smooth-constant rate.

Thanks to those who gave suggestions on solving popping noise. The popping noise was at 10 pops per second when I measured it on the trace so it seemed reasonable that it could be related to the Audio to Buffer setting of 100ms. I tried changing this setting with no change in popping noise. The solution was to turn off the WiFi modem when popping noise stopped - great. Thanks for the suggestion. :smiley:

Thanks for letting us know what solved it. I will mark this “[SOLVED]” in that case.


Gale