Plugins won't display under New

Hello! Long time listener, first time caller. I mistakenly removed v3.1.3 this week from Ubuntu 22.04 and lost several years worth of plugins. I’ve gone through and re-downloaded most of them (guitarix, TAP, etc.) but cannot for the life of me remember how to add them to the plugins repository under the Effect tab. I’ve added all those downloads into the plugins folder but none of them are displaying under New in the Plugin Manager. I’ve gone back as far as 2.4.2 and reinstalled v3.13 via both Snap and Ubuntu Software with no success. Any tips? Thanks!

IIRC 2.x.x Audacity was only available as 32-bit, whereas 3.x.x can be 64-bit.
32-bit plugins can only work in 32-bit Audacity, 64-bit plugins can only work in 64-bit Audacity …

https ://

Not the case for Linux. 64-bit Audacity has been available for Linux for a long time. When apps are installed from the Linux distro’s repository, the package manager will automatically choose 32-bit or 64-bit to match the OS.

Uninstalling Audacity should not affect plug-ins that were installed with the package manager, or plug-ins that were placed in ~/.audacity-data/Plug-Ins/ (unless you manually deleted that folder).

If that’s the version in your distro’s repository, then I’d recommend that you use that version.
Any compatible plug-ins that are installed on your system should be available in Audacity’s plug-in manager. See:

Thank you both so much! I did indeed manually delete the Plug-Ins folder after several installations, which was not a wise move but a learning experience.

Since my original post, I was able to add a small amount of plugins (KPP-1.2.1) but not the majority. KPP plugins end in .so, whereas the rest end in others (.h, .c, .py, etc.) and I wonder if there’s some sort of parameter or set-up within JACK that allowed me to originally add the remainder. I installed all of these plugins several years back and cannot for the life of me remember the process but before deleting I was able to access several hundred plugins through the Effect tab.

As far as their source, I downloaded most of the plugins through various GitHub pages and Linux-Sound ( as .tar packages and extracted them into the Plug-ins folder.

Thanks again for all of your help and suggestions!

The easiest and safest way to install software on Linux, is the use the package manager to install the software from the distro’s repository. Personally I would say that non-experts should only install software this way. The Ubuntu repository carries thousands of plug-ins, so it’s not really necessary for most users to install plug-ins from other sources.

When it comes to the plugins that I’ve noted (Guitarix, TAP, Caps), how would I add these through the distro’s repository? Apologies for perhaps the basic question.

“Guitarix” and “tap-plugins” are available in the Ubuntu repository, so yes you can install them using your package manager.
I’ve not heard of “Caps”.

Hello! I’ve gone ahead and downloaded both Guitarix and TAP plugins from the Ubuntu repository. Should these automatically display under New Effects/Plugins in Audacity? I’m still not seeing them and wonder if there’s an in-between step. Thanks!

Do you really mean “downloaded”, or do you mean “installed”?
When they are installed, they should appear in the Plug-ins Manager where you can enable them.

I ran sudo apt-get install guitarix && sudo apt-get install tap-plugins, which told me that “guitarix is already the newest version (0.42.1+dfsg1-3)” and “tap-plugins is already the newest version (1.0.0-1).”

I was able to solve the issue! I had initially installed Audacity via snap (v3.1.3 by default), so I uninstalled and reinstalled from the Ubuntu repository (v2.4.2 by default) and all of the plugins appeared.

Thanks for the update. That’s the version that I was suggesting. Glad to hear it’s now working :slight_smile:

Snap packages run in a “sandboxed” environment, which can prevent them from accessing external resources, such as plug-ins.

Even though I solved my initial problem regarding plugins, a second one has developed. Whenever I close Audacity and later reopen the program, specifically none of the Guitarix plugins work. When I click Apply on a highlighted track, nothing happens; no change occurs to the piece of highlighted audio. I have to delete pluginregistry.cfg and pluginsettings.cfg, and then re-add all of the plugins once I open the program in order for them to function. Once I close the program, I need to repeat this process. Any leads on why this issue seems to only affect those specific plugins? Thanks!