Plugins cannot Enable

Hi all,

I’m running Audacity on Windows 10. Every time i try to load a plugin (YouWaSHOCK, Spitfish De-Esser, TAL Reverb, etc.) It appears in the enable/disable menu, but when i try to enable it, i get an error popup that reads: “failed to register, could not load library.” Here are the steps i take to download a plugin:

-Download Audacity Fresh after a complete uninstall (i’ve done this about 6 times.)
-Install the .dll file for the plugin.
-Place the .dll file into :c/Program Files/Audacity/Plug-Ins.
-Open Audacity.
-Go to “Add/Remove plugins”.
-Click “Enable” on the plugin i want.

I have tried both the 34 bit and 64 bit versions of audacity 3.0.4. It made no difference. I’ve installed Audacity to Program Files (x86). No difference. When a 34 bit version of the plugin is available, i specify to download that one. No difference. It’s driving me mad!

Some plug-ins don’t support in Audacity. :frowning: It’s up to the plug-in developer (not the host developer).

Audacity doesn’t support VST3 plug-ins (usually with a .vst3 file extension) at all. “Regular” VST plug-ins usually have a .dll extension and these MIGHT work.

I have tried both the 34 bit and 64 bit versions of audacity 3.0.4.

32-bit plug-ins won’t work with 64-bit Audacity, and 64-bit plug-ins don’t work with 32-bit Audacity.

Most commercial plug-in developers have a list of officially supported hosts on their support page. At least one specifically lists Audacity as NOT supported (I think it’s Auto-Tune), Sometimes they’ll work (or partially work) if they are not officially supported.

With free plug-ins it’s usually hit-or-miss because they usually don’t have the staff or budget to test & debug with every audio editor and DAW.

…I don’t think I have any 3rd-pary effects, but I have 3 analyzer effects that do work. (dPMeter, Youlean loudness meter, and Bitter bit-depth analyzer.)

Alright then, could I maybe get a list of steps on how to install YouWaShock and Spitfish to audacity? because everything i’ve tried so far has not worked.

I’ve just been on and noted that its copyright is dated 2007 and has Win98, XP and Vista. Could be that this project has been abandoned and is no longer in development.

Audacity has new version and I notice that some of the plugin dont run… so I reInstall the lower version of audacity and yeah I can use you wa shock again… this can be an option…

If they are 32-bit plug-ins you can try the 32-bit version of Audacity 3.1.0.