Plugin Conflicts and When to Compress

I recently installed the RMS-Normalize plugin and when I clicked ok, nothing happened. No pop up saying it was working. I waited, like, 15 minutes, etc. Bupkes. And I couldn’t see any difference in my wave pattern from my recording. Still, I tried compressing and limiting it, and when I did the ACX check, the sample failed the peak (by how much I forget).
I have SetRMS installed. Could there be a conflict between the two?

I also noticed the debug button on the RMS-Normalize window and clicked it. The following appeared in the box:

error: bad argument type - NIL
Function: #<Subr-/: #9516af8>
Function: #<FSubr-LET: #95115c8>
Function: #<Closure-NORM: #93f28c0>
#<Sound: #5d0ac88>
Function: #<Subr-APPLY: #9512bc8>
#<Closure-NORM: #93f28c0>
(#<Sound: #5d0ac88> NIL)
Function: #<FSubr-COND: #9514518>
Function: #<FSubr-LET: #95115c8>
(DOLIST (A ARGS) (COND ((ARRAYP A) (SETF NEWLEN (LENGTH A)) (COND ((AND LEN (/= LEN NEWLEN)) (ERROR (FORMAT NIL “In ~A, two arguments are vectors of differing length.” FN)))) (SETF LEN NEWLEN))))
Function: #<Closure-MULTICHAN-EXPAND: #3f3a0c8>
#<Closure-NORM: #93f28c0>
#<Sound: #5d0ac88>

Yoicks! I can’t code or even read most of it, so the above makes no sense to me.

I’m busy reading up on compression now, so will hopefully figure out how and when to use it and what presets I should use. But if anyone can offer some insights or links, that would help.

And if I may vent just a little here, I’m beginning to despair that I shall ever get a usable recording. I agree that I should probably fix this at the mike, and will probably re-record (yet again) my first chapter. But it’s just so frustrating in the meantime.

From where?
In the case of plug-ins that are not shipped with Audacity as standard, always link to the page where the plug-in can be downloaded from. If downloaded from a post on this forum, click on the “Permalink” button of that post to get the post link into your web browser address bar, then copy the address from the address bar.

I pulled it from your post to this forum: Wouldn’t have done it from anywhere else (not that you’d know that, but just to reassure you).

Just so I’m not being a complete idiot, how long does it take per minute to normalize a track? It could be I just didn’t give it enough time. The funny thing is, with other tools, I usually get a pop-up saying it’s working. This didn’t have anything, but I don’t think the SetRMS plugin did, either. And, as I recall, it took a fair amount of time. That being said, I could really see that it had done something.

If RMS Normalize isn’t required to do anything, it won’t do anything. If you have a loud, rich, robust reading style and, from your comment, your blue wave peaks are high, chances are good RMS Normalize isn’t needed. I don’t know if it will normalize down as well as up. I assume so.

So if you get it that far, then run Limiter.

– Effect > Limiter: Soft Limit, 0.00, 0.00, -3.50, 10.00, No > OK.

Now run ACX Check to see what happened.


Reading high, loud and robust is most unusual. You are supposed to read slightly low so your reading style is not likely to peak over 100% and cause distortion. Target is peaks about -6dB to -10dB—yellow-ish on the recording meters. Microphone spacing is between fist and shaka

…and use a pop and blast filter.

If you have that (you do save WAV copies of all your original readings, right?), open one of the original readings and RMS Normalize to -20dB, Effect > Limiter: Soft Limit, 0.00, 0.00, -3.50, 10.00, No > OK. Then run ACX Check and see what happened.


Missed one. You can measure RMS by yourself with Analyze > Contrast > Measure Selection. Read it and then Close.


Wouldn’t be the first time I’ve lost a forum thread.

If you’re in Mono (one blue wave), drag-select a twenty-second portion of your raw, unprocessed speech, File > Export Selected: WAV (Microsoft) 16-bit and post it here. Scroll down from a forum text window and Upload Attachment.

If you’re in Stereo (two blue waves), ten seconds. You should probably be reading in Mono. It’s much more efficient and the corrections are more likely to do predictable things. ACX recommends (softly) submitting in Mono.

There are shortcomings to generating a standard suite of AudioBook corrections (Mastering). There will always be an outlier with an odd track, and someone is going to find an “Undocumented Feature.”


Oy. Thanks for the clarification. I am probably too robust. Stage and speech background, and I’m old school in that I learned to project. Have the pop filter. Will try running the effects again, then will post as per your request in the below comment.

Clip of raw recording is attached. Selected the whole recording, tried to do the RMS Normalize and got a Validation Error: Value not in range -36 to -6. Tried hitting debug and got the same thing. I did the analysis you suggested in the other comment and got -23.8 for both foreground and background, Contrast Result: WCAG2 Fail and Difference 0.0 dB Average RMS. The photo is the ACX Check results on the raw .wav file (at 32 bit).

And I get it re the shortcomings of doing a standard suite of AudioBook corrections. Which is why I’m trying to learn as much about this kind of mastering, in general, as possible. I figure the more I learn about it, the more likely I’ll be able to solve my own problems.

Something is wrong.

I applied RMS Normalize and Limiter to your clip.
Screen Shot 2017-05-31 at 09.47.36.png
I’m not in a good place to stop and listen. I’ll do that when I get home.


The only shortcoming I can tell is the word “Cathy” at 3-1/2 seconds. For some reason that word is stressed and turns into mild distortion when I process it. Everything else sounds like an audiobook, and you would even miss “Cathy” if you weren’t paying attention.

You can see it sticking up above all the other blue waves if you open the clip and look. But that’s not what’s wrong. That’s just a nit-picky theatrical problem.

I’m not sure where to go from here other than the generic Windows solution of start over. Close everything and Shift - Shutdown Windows. Start it up and see if you still have these problems. I assume you have safety copies of all your work and you won’t flush a chapter or two if you restart the machine.

Also, Do Not start any other sound program. Audacity does not Play Well With Others to quote a grade school report card. No games and no Skype, Conferencing or equivalent.

Shift-Shutdown is important because if you do a simple shutdown, Windows tries to help you by leaving some services working. It restarts much faster that way.

I personally wouldn’t put periods in my filenames. A period is one of the characters that can have meaning to the computer other than what you intended—particularly in Windows which likes to hide parts of the filename…to help you.


Well, I did as you suggested and re-started Windows. I shut down completely and waited several minutes. After booting up, I did not even open my browser, but went straight to Audacity, opened the file, Cntrl A, and same problem: Validation error, Value not in range -36 to -6.

Since yesterday, I downloaded Chris’s Dynamic Compressor and it looks like it’s evened things out. The chapter passed ACX Check, and it looks a little more like what they show in the ACX help videos.

But I am still perplexed by the error I’m getting. Debating unloading the program, doing a registry clean up w/ CCleaner, then reloading it, including the plugins, but without the Set RMS one.

SetRMS is a different program, and that one can have problems. SetRMS is the proof of concept program written on a paper napkin with felt-tip pen. After it proved valuable, RMS Normalize was written to make it a real plugin with control panel, buttons and options.

Chris’s Dynamic Compressor

It will be interesting to see if Chris Compressor makes it past ACX Human Quality Control. ACX wants a specific number of seconds of buffer and gap, room tone, etc, etc in your readings. Chris may not like that.

You are warned that Chris requires Some Sound in the first few seconds of processed performance. When I use it, I leave some unedited trash at the top to give Chris something to chew on, and then go back in later and cut it off…but I’m not reading for AudioBooks. ACX may not like Control-L (Make Silence) because that leaves blackness-of-space, dead silence, non room-tone at the beginning.

Chris can simulate broadcast compressors very well which is what Chris said when he wrote it. He wanted to listen to opera in the car—everything between tutti orchestra and one violin in the south forty. I use it to compress a “wild” podcast so I can listen during a hike without the loud voices blowing my ears off.

Chris was never popular for AudioBook mastering because sometimes you can hear it working and ACX hates that.


Wonder if they’ll get peeved if I upload two samples, one compressed and normalized via Audacity and one via Chris’s. The turnaround on the quality-control is crazy-making long. I get that they’re busy, but I don’t want to go reading the whole book if they’re going to have issues.

Every so often you say something a little off center.

SetRMS is not “installed.” SetRMS is raw Nyquist code/text you copy and paste in the Nyquist application window.
Screen Shot 2017-05-31 at 6.13.32 PM.png
I don’t think you ever said which three-digit number Audacity you’re using. RMS Normalize only works on Audacity 2.1.3.