Plug-ins won't enable

Hello, Everyone!

I’m having problems with, well, plug-ins. I have tried lots of different ways of saving them and 3 different plug-ins (of the same type), all made by different comanys/creators. I have tried .vst and .dll plug-ins, but all of them give the same error, something like not being able to load libarary.
The plug-ins I tried were: REZ3, Resom, Palmspeaker;

It could be a couple of things…

32-bit plug-ins only work with 32-bit Audacity and 64-bit plug-ins only work with 64-bit Audacity.

Audacity doesn’t support VST3 plug-ins, only VST2.

Audacity doesn’t support VSTi virtual instruments, only VST effects.

Some plug-ins simply don’t work in Audacity. With commercial (paid) plug-ins they usually have a list of officially supported hosts. Audacity is rarely officially supported (probably because Audacity most users won’t pay for plug-ins). Sometimes they will work even though Audacity isn’t officially supported but if not, “You can’t complain”. With free plug-ins it’s just hit-or miss…

Thanks for quick respnse,

I am using a .dll plugin, for free, but many internet examples show it works. The website says it is comaptibile with 64 bit and 32 bit. Also i tried plug-ins from the offical audacity site, tbh i tried a lot of things, even older versions of audacity, nothing.

REZ3 (from 2014!) is a 32-bit plugin. It does run on the 32-bit version of Audacity, but not fully functional …

REZ3 (free) in 32-bit Audcaity.gif

when using jbridge …

Thanks soo much for clearing that up, i will just use the 32 bit ver. of audacity instead, also thanks for responding this fast.

Just realized it didn’t work, sorry if i wasted your time :slight_smile:

REZ3 does have some effect :
sometimes necessary to stop then start Audacity playback each time you change the REZ3 preset for changes to take effect.
REZ3 does have some effect.gif

after i enable REZ3, i close audacity, and as soon as i click REZ3 in the options menu, audacity crashes

If you want to use VSTi plugins you’ll need another host: Audacity does not support them …

I just said it is a .dll

Saying that it’s a dll does not help.
VST2, VST3, VSTi are all “.dll” on Windows.
(dll = dynamic link library. They are shared libraries that are used by Windows for a vast range of things, not just audio plug-ins)

Hello, sorry for the waste of time, but i just realised it was working, but as soon as i close audacity and open it again, to make a new project using REZ3, it just crashes when i select REZ3 from effects, but right after enabling it, it does in fact work, but only that one time. The only question I have left is, how can I get it to, well, not crash?

VST3 plugins can have their own suffix …
VSTi plugin options.png

and knowing that, how can I make REZ3 stop crashing, along with audacity?