Plug-ins won't enable [SOLVED]

Mac OS 10.14.2 (18C54); Audacity 2.3.0
I recently had a problem with Audacity unwilling to start … a forum suggestion fixed that. However, prior to reaching out, I had redownloaded and reinstalled Audacity. My applications folder used to have an Audacity folder that included the app itself and other things. Now it has just, (possibly because of an update that bundled effects with the ?). In any case, I use an effect (Chris’s Compress & Dynamics 1.2.6) and an analysis effect (ACX check) that do not come bundled with Audacity. Both effects show when I go to Add/Remove Plugin. Both show as disabled. When I click to enable and click OK, both initially say they’re enabled but don’t appear on my dropdown effects or analyze list, even after a restart. I go back to Add/Remove and both again show as disabled.
Looking back at the C&D 1.2.6. instructions, I see:10.14.2, I see:
Ensure you have the latest version of Audacity installed.
Download Chris’s Dynamic Compressor plugin for Audacity.
Double-click the zipped file to open or extract it.
Move “compress.ny” to Audacity’s plug-ins folder.
(then enable it)
If I re-download, the file comes direct as compress.ny, not needing to be unzipped; however, I have no app/audacity/plugins into which to put it. How do I get these two crucial effects to work?

Due to trying to fix the other issues, the Audacity configuration files may have become messed up. I’d suggest removing / deleting these configuration files so that Audacity becomes reset to “out of the box” factory defaults.

The three files involved are:

On macOS, these files are located in ~/Library/Application Support/audacity/
Use the “Go” menu, then “Go to folder” and copy / paste the folder location.
With Audacity completely closed / shutdown (NOT running in the background), delete the three files that I’ve listed above.

When you restart Audacity, you should see the “Welcome” screen.
The only enabled effects will be those that are shipped with Audacity by default, so you will need to enable your custom plug-ins.

OS 10.14.2 (18C54); Audacity 2.3.0

Tried this. Restarted Mac. Audacity comes up (but has lost the Audacity picture in Applications (picture 1), but same problem: Effects that say they’re bundled with Audacity and say they’re active (Add/Remove Effects list) are not active (picture 2). Ditto Analyze (picture 3). Manual seems to indicate added plugins should be in App Support/Audacity/Plug-Ins folder, so I added my two crucial Nyquist ones there (picture 4). Same result as above … nada. I then looked closely at the Add/Remove Plug-Ins. My Chris’s Compress & Dynamics 1.2.6 was again disabled, but had as its location Applications/Audacity/plug-ins/compress.ny, so I added that folder to Applications (picture 1). Still no luck.
Screen Shot 2019-02-10 at 12.25.03 PM.png
Screen Shot 2019-02-10 at 12.27.05 PM.png
Screen Shot 2019-02-10 at 12.22.09 PM.png
Screen Shot 2019-02-10 at 12.19.23 PM.png

What is this a picture of?

Is listed in your Applications folder, like this:


The picture is what Audacity looks like if I punch the Applications folder in the dock … I don’t understand it either. I showed the pic because an earlier implementation of Audacity dropped a Plug-Ins folder right on Applications; I made a new one when I saw that the ‘Enable Plugin’ list gave the address of my nyquist plugins as that folder.

Maybe it would be better to wipe out Audacity completely and reinstall, saving the Nyquists in separate folder and then bringing them back in according to instructions??

I’m not an expert on macOS, but it sounds like Audacity is not installed properly. Yes I think it may be best to remove Audacity completely and start again from scratch (following all of the instructions carefully :wink:)

The installation instructions for Audacity are here:

Mac OS 10.14.2 (18C54); Audacity 2.3.0 (new install)
Short story: Your suggestion worked
I did clear out the audacity program and the library, then reinstalled and restarted. That worked. I wanted to add two Nyquist plug-ins: (1) Chris’s Compress & Dynamics 1.2.6 (an effect) and (2) Acx-check, an analyze function. I downloaded both. There is no longer an Audacity folder in Applications … just the app. So, although the manual says to drag into the plug-ins folder in Applications, I went to Library/Application support/audacity, where there was a plug-ins folder. I put both in that folder, quit Audacity, restarted. In the Add Effects drop down in effects, I found the compressor and activated it. In the Analyze drop-down, no Acx-Check. The download had a .txt extension, which I stripped. That finally got ACX-check to activate.


Super :smiley: