Plug-ins Not Appearing in Plug-in Manager

He, everyone,

I could really use some help. I have the most recent version of Audacity and I have Windows 10. Last night, I successfully downloaded the ACX Check plug-in and the Spitfish De-esser plug-in. I cut & pasted them from my laptop’s downloads folder to the plug-in folder of Audacity. However, when I opened Audacity & went to the top menu to open the plug-in manager box (from the Tools, Effects, or Analyze options - I tried all three), neither ACX Check nor Spitfish were anywhere to be found. I tried closing & reopening Audacity as well as deleting both plugins and going through the process all over again, to no avail. I cannot add or enable something which doesn’t even appear to be found or recognized in the first place.

What am I doing wrong? Did I miss a step or detail? I’m thoroughly perplexed. Per one suggestion, I right-clicked on “Properties” on the plugins then on the security tab, and checked all the boxes for adding access/permissions for all users. That yielded no positive results, either.

I apologize for appearing obtuse, but any help would be deeply appreciated.

Thank you in advance!

“ACX Check” is a “Nyquist plug-in”. Installation instructions are here:

Spitfish is a 32-bit VST plug-in, and so it will only work in a 32-bit host application. The current version of Audacity is 64-bit and so can only support 64-bit plug-ins.

Apparently the latest version (currently v3.1.2) is also available in 32-bit … Old Audacity versions download
That version would still allow 32-bit plugins to be used.

The latest version of Audacity, 3.1.3, is available in 32- or 64-bit versions here: Audacity ® | Download for Windows

When I click on that link the 64-bit version is forced on me …

The 64-bit build is the default / main release. The download starts automatically (not a great idea imo, but that’s how it is).

If you specifically need the 32-bit version, cancel the automatic download, then click on the link: “Audacity 3.1.3 32 bit installer”, (or for the ZIP 32-bit: “Audacity 3.1.3 32 bit zip file”).