please help, Yeti mic not showing up + error code

For some reason when I open Audacity the only input option it shows is for the built-in mic on the computer, I have tried opening the preferences tab in Audacity to select my yeti microphone but it’s not showing up there either. Now I have been able to get it to show up previously, but those times when I would go to record it would show an error like 9332 or 9932 something around there saying that there was some sort of issue with the input or maybe the plug-in the issue? Now I can’t get it to pop up again so that I can tell you exactly what the error says because I can’t even get the microphone to show up in Audacity or just on the laptop when I go to the sound preference settings. Any ideas? Also it seems that my mute button on the yeti microphone has quit working? I’ve only use this microphone a handful of times and it says that when you hit the mute button it’s supposed to flash to let you know that it’s muted but if I click it it just stays the solid light and does nothing, it’s not something I’m super worried about unless it’s somehow affecting the issue at hand.

Please help, I just want to record :cry: :confused:

I think Yetis are up to five different versions. Which one do you have?

Do you have another USB cable?

Plug your headphones into the Yeti. Turn the GAIN control on the back all the way up. Turn the headphone volume on the front up as you listen. Can you hear yourself?

If you change the cable and the Yeti still doesn’t work right, it may be broken. Can you try it on another computer?


Be sure that Apple is seeing your microphone. From the Blue Yeti site:

Connect Yeti with the supplied USB cable.
Click Apple menu -> System Preferences.
Select Sound.
Click the Output tab, and select Yeti Stereo Microphone under Select a device for sound output.
Click the Input tab, and select Yeti Stereo Microphone under Select a device for sound input.
Exit System Preferences

If your Yeti does not appear under Apple System Preferences, then it may be best to contact Yeti for assistance. Perhaps there is an updated driver that you need. Also, see koz’s comments, above.