Please Help!! Audio delay in headphones. Hard to record.

I am new to Audacity. I have researched online and youtube for information to get me started. I understand the basics…(I think) :wink:

Here is the set-up that I have recently purchased in effort to record my music and songs:

Alesis i02 express USB Recording Interface
Audio-technica AT2020 Cardoid Condenser Mic
Peavey cable - to connect the mic to the interface.

I also have a small amp for my acoustic/electric guitar, which I use the cable from the guitar to plug-in to the interface for audio through the amp on playback in Audacity. And, the audio comes through the amp just fine.

I also have headphones that I plug into the interface …in hopes to hear the audio while I record, BUT…I have no sound through them. So thats where I need HELP! PLEASE!

And while I’m at it…I have painfully been trying to install ASIO4ALL and use it in Audacity. I “thought” I downloaded it and maybe installed too. But there’s no sign of it that I can see in Audacity.

I redownloaded the Audacity installer version straight from the Audacity website on 04-01-2015, so whatever version that was is what I have. Also, I am using Windows 7.

If anyone can give me SIMPLE (please) STEP-BY-STEP with this I would certainly appreciate it. I have honestly put long, tiring hours in this over the past few days and I can’t quite get to where I need to be. On a better note…In testing this out tonight I did record 2 quick songs and had playback through the amp, but I wasn’t using headphones. Then I tried the headphones - connected straight into the ALESIS interface, and the audio was delayed :frowning:

Thanks to all who help others!

Play Music,

Docs for the device here .

Alesis Forums here if you need help using your interface.

If you are trying to play a backing from Audacity to Alesis, the Alesis must be the playback device in Audacity’s Device Toolbar.

Audacity can’t use ASIO4ALL unless you compile Audacity from source code. I am sure you don’t want to do that, nor should it be necessary if you are plugging headphones into the interface. Describe the delay - what is delayed between what? Are you trying to record a mic and a guitar at the same time, or playing an already recorded guitar track in Audacity while recording your mic?


Are you listening to a backing track in your headphones? If not, you don’t need the headphones to hear your guitar… :wink:

There are audio interfaces with zero-latency hardware-monitoring, where the monitoring signal does not pass through the computer. But, I don’t think your interface has that.

You can also use an external mixer for zero-latency monitoring.

There are ways of minimizing latency (delay) through the computer and people often get it down to an acceptable level. I’m not an expert on that, but I know low-latency is the main advantage of ASIO. There’s no way to completely eliminate latency with a multitasking operating system. There is an input (recording) buffer and an output (playback/monitoring) buffer, and a buffer is also a delay.

Like I said, I’m NOT an expert on this stuff, but generally the idea is to reduce the size of the buffers as much as possible without getting “glitches” in your audio. It helps if you avoid running multiple applications and minimize background operations. Some people get better results by turning-off their anti-virus and turning-off Wi-Fi if they are on a laptop. A faster computer* also helps. Oh… It also helps to avoid “high resolution” audio because there’s less data flowing-through and the computer can process & save it faster, and the buffers can be smaller. If you are recording at 96Hhz/24 bit, you might get lower latency with 44.1 or 48kHz/16-bit. (Of course, Multi-track recording also requires more data, bigger buffers, and more latency, but you won’t be multitracking with your 2-channel interface.)

…I guess you could say I’m an expert on the problems, but not the solutions! :smiley: :smiley: The only solution I’m sure of is, “Don’t monitor yourself through the computer!” (It’s perfectly OK to monitor the backing track from the computer because it was recorded “last week” and a few more milliseconds of latency doesn’t matter.) :wink:

FYI - ASIO4ALL replaces part of the Windows driver stack and it allows non-ASIO hardware (hardware without true ASIO drivers) to work with ASIO compatible software . So, the software “sees” an ASIO hardware device and the software can use ASIO protocol.

ASIO4ALL doesn’t help if your software (Audacity as-supplied) doesn’t support ASIO.


  • Computer speed is mostly an indirect effect… It not so much about how fast the computer can process & save the audio or how much CPU power is required… It’s how quickly the computer can finish all the background stuff (updating the clock & display, reading the keyboard & mouse, and whatever else it’s doing) and get-back to reading & writing the buffers before the recording buffer overflows or the playback buffer underflows.

The Guide for the Alesis io2 express says:

MONITOR MIX – Blend in any amount of zero-latency signal from your inputs with the output of your computer

so I assumed that listening to the inputs would not have delay.


But, I don’t think your interface has that.

Actually, I think it does from a greatly magnified view of that knob that says DIRECT and USB.

However, One of the comments on Sweetwater points out this thing is probably USB 1.1 and that can create speed problems of its own, absent ASIO.

But, I think this is a simple setup problem in Audacity. Turn off Playthrough and turn on Overdubbing.

Now all we need is the poster to arrive so we can tell him. Ho doubt he’s used to forums that take six months to come back.

This is not one of those.