Playback will not activate since latest Raspberry Pi OS (Raspbian) update

I’m on Raspbian, the version of Debian Buster optimized for Raspberry Pi, which as it happens was renamed to Raspberry Pi OS in the latest update.
Audacity version: 2.2.2., the latest version that the standard repos give, AFAIK.

I only installed Audacity on the Pi a couple of days ago, and was using it for a project, which went really surprisingly well; Audacity functioned as expected on any other device.

However, since then, the new OS update came, and ever since, when I go to use Audacity, whenever I hit the “play” button, playback doesn’t actually start. I don’t mean that there’s no sound, or that the app freezes, but that the “needle” just doesn’t move. It can still be stopped or pause after hitting play, other features seem to be working fine: the only function seemingly impaired in anyway is the playback, which just doesn’t happen.

Any idea what might be causing this?

Could it be some kind of compatibility issue with the new distro update? Or am I being dumb and missing something really basic here?

If it is the case that there’s some issue between the distro version and the application, do I just have to wait for some patch from either RPi or Audacity, or is there some decent workaround that might solve my problem in the meantime?

(Obviously I’m aware the distro version is very new, but has anyone else encountered anything similar?)

Btw, I forgot to mention that I installed from APT, not from source code.

Same issue here.
I have a R Pi 2 1Gb with Raspberry OS ver May2020 (Linux)
Audacity 2.2.2 installed from distro source

This issue is due to latest update on OS
You can find this here:

They have made small change to audio, and, I think, Audacity team has to adapt the software

Meanwhile, I think we have to go back to the previus vers of OS, wich is Feb 2020, in order to use Audacity

Good luck

It works now, just do apt upgrade.

Hi there,
Can you clarify how you got Audacity to work with RPi 4B?
That is, what exact command line did you type into Terminal on your RPi?
Also what version of RPi Os do you have
And what version of Audacity do you have?
Thanks much

I have Audacity 2.2.2
And typing in

uname -r



Was able to get Audacity 2.2.2 to work on RPi 4b by connecting a usb audio interface (with headphones) to Rpi and selecting that device as mic and output in Audacity. Could record and playback, playback head finally moved!

Raspberry Pi 400, so no audio jack, only HDMI audio output
$ cat /etc/os-release
PRETTY_NAME=“Raspbian GNU/Linux 10 (buster)”
NAME=“Raspbian GNU/Linux”
VERSION=“10 (buster)”

$ uname -r

Audacity 2.2.2. Installed using the add software tool.

Same issue. I can open mp3 files but clicking play doesn’t work. I have tried upgrading the operating system, and doing an update.
The only output device showing in audacity is dmix. I don’t have any USB audio devices to test a work around.I’m new to both this machine and Audacity.

Perhaps you could go back to the version that works?


The new Raspberry PI update + upgrade seems to have fixed this issue for me by adding PulseAudio.