Playback through computer speakers

I am using Audacity 2.0.5

My linux system is: Ubuntu 14.0.4 LTS

I am using a Zoom H2n recorder through a Focusrite Scarlett 2i2

I am an absolute beginner with Audacity. As the subject title states, I am unable to hear the recording through my computer speakers. I did check the FAQ’s, and the online manuals.

I don’t know where to begin to update to the latest Audacity release.

The version that I have was installed on my computer when I bought it.

That’s a little too scrambled.

I am using a Zoom H2n recorder through a Focusrite Scarlett 2i2

I can’t think how you have that connected. The H2n has a USB connection and will stand-alone record. Why would you need the Focusrite?

What’s the goal? “I want to record my voice for a podcast.” Get us close.



Yeah, the Zoom H2n was not recognized by Audacity. It did allow me to use the Focusrite.

I occasionally record my friends and I jamming. I would like to edit these recordings in Audacity.

Thanks for the reply!

My Zoom H4 has a decision tree I need to climb. I have to decide whether I need it to act as a live USB microphone or a USB file transfer device, and they’re different. So that may be able to resolve one problem right there. Dig in your instructions.

Audacity can establish a sound pathway independent of what the rest of the operating system is doing, so it can be a dance.

We need to wait for one of the linux elves to arrive.


As koz says - check the Zoom manual, The options are:
a) Record with the Zoom as a stand alone recorder onto a flash memory card, then transfer the recording from the flash memory card to your computer for editing.
b) Connect the Zoom via USB to the computer and set the Zoom to work as a USB microphone.

Option (a) has the benefits of being portable and mechanically silent.
If your computer has a flash card reader, you can simply put the Zoom’s flash card (after recording) into the card reader then drag and drop the WAV (or MP3) files from the card to your computer hard drive. Don’t attempt to edit the recording directly from the flash card.

Steve was writing while I was. I’m not sure if he answered all your questions so I will just post anyway.

If you connected Zoom after you launched Audacity, do Transport > Rescan Audio Devices in the Audacity menu bar.

Did the recording show tall blue waveforms? If not, read Steve’s reply.

For the rest, choose the playback device in Device Toolbar.

Ubuntu uses a sound mixing API called “PulseAudio”. When you select the “pulse” or “default” playback device in Device Toolbar, you are choosing whatever is the current PulseAudio playback device.

To make it easy to select the playback and recording devices that pulse uses, and to control the volume of those devices, open a terminal and install PulseAudio Volume Control (pavucontrol):

sudo apt-get install pavucontrol

You can also choose built-in playback (or recording) devices in Device Toolbar if you choose the (hw: 0, <some number) playback (or recording) device in Device Toolbar. In this case, instead of using pavucontrol to choose which output (or input) is being used, you would use ALSAmixer to choose the output (or input) device that the (hw: 0, <some number) device refers to.

Choosing pulse or the (hw:) device has different pros and cons. Pulse can freeze up, though there are workarounds to set different latency values. Choosing the (hw:) device lets you access the hardware without going through the pulse mixing layer, but that will not work if another application than Audacity is using your sound device.

It is probably nothing to do with your problem, but it is possible to uninstall 2.0.5 and install an unofficial PPA of Audacity 2.1.1:

Installation help:



That’s a lot of information! Thanks everybody!

I’ll work on it this weekend when I have more time.

Have a good night!


I am trying to record my bass through the Scarlett 2i2, with a click track. The zoom H2n is disconnected.

I can hear the bass through headphones, from the Scarlett. The Scarlett is not recognized by Audacity.

I only hear the click track through the computer speakers.

I did a lot of searching, nothing applies. I did have it working before when the Zoom was connected.

Thanks for your help.

I’m beginning to suspect a computer problem.

Acoupla times I was unable to quit Audacity. The screen would turn a transparent grey. I could still see the Audacity screen behind it. I had to click ‘Force Quit’ to quit Audacity.

Then for a minute, I could monitor the incoming sound. I was not able to before. I was able to see the device in sound settings, on my computer. Which I could not earlier. And then suddenly, the screen went grey as I described earlier. Although I had not tried to quit Audacity at that time.

Now it is back to not working. The computer shop isn’t open until Monday. I’m going to give them a call then.

You should be able to overdub with the Scarlett. Put its Direct Monitor switch on. Turn Transport > Software Playthrough off in Audacity, turn Transport > Overdub on.

Scarlett will not appear of its own accord in Audacity if you connect the Scarlett after Audacity is already running. If that is the case, do Transport > Rescan Audio Devices in Audacity.

Ensure you choose the Scarlett (hw:1,x) device as recording and playback device in Audacity. This may help avoid freezes.

If after recording you want to play what you have recorded through the computer speakers, change the Audacity playback device to the computer speakers.

Try another USB cable if you cannot perform the steps above.

What are your computer specifications (RAM, and processor speed)? Ubuntu is a “heavy” OS. If your computer is underpowered you could consider Lubuntu.


Thanks for the quick reply Gale!

I will post the results in the order that the suggestions were made.

Direct Monitor Switch: On.

Software Playthrough: Off. Overdub: On.

Scarlett set as recording, and playback device. The freezes have improved.

Setting Audacity to Front allows playback through computer speakers.

Your instincts about the USB cable were correct. The cable supplied with the Scarlett allows Audacity to function.

RAM: 3.8 GiB Processor Speed: Intel® Core™ i5-2400 CPU @ 3.10GHz × 4

I am only able to record on one channel, as the Scarlett has two inputs.

Audacity is functioning as it should.

Thanks for your help!